summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJeffrey C. Ollie <jeff@ocjtech.us>2008-09-12 21:38:45 -0500
committerJeffrey C. Ollie <jeff@ocjtech.us>2008-09-12 21:38:45 -0500
commit64a567d2fbd65a04bbec619947957356dcc73c8c (patch)
treeb172bd63bd19144ddb7b011346ce7c91deabaa06 /CMakeLists.txt
parentc0e9be3293f15aec9e426f05fe6eb52a10cb2b3f (diff)
downloadlibresample-master.tar.gz
libresample-master.tar.xz
libresample-master.zip
Generate some documentation.HEADmaster
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index de535cf..e70429f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,6 +23,8 @@ find_library(HAVE_LIBM m)
pkg_check_modules(SNDFILE sndfile)
pkg_check_modules(SAMPLERATE samplerate)
+find_program(DOXYGEN NAMES doxygen)
+
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/configtemplate.h ${CMAKE_CURRENT_BINARY_DIR}/src/config.h)
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/libresample.pc.in ${CMAKE_CURRENT_BINARY_DIR}/libresample.pc)
@@ -50,3 +52,9 @@ if(SAMPLERATE_FOUND)
endif(SAMPLERATE_FOUND)
install(FILES libresample.pc DESTINATION ${LIBDIR}/pkgconfig)
+
+if(DOXYGEN)
+ add_custom_command(OUTPUT docs/html/index.html COMMAND ${DOXYGEN} docs/Doxyfile DEPENDS include/libresample.h)
+ add_custom_target(docs ALL DEPENDS docs/html/index.html)
+endif(DOXYGEN)
+