summaryrefslogtreecommitdiffstats
path: root/buildah.spec
diff options
context:
space:
mode:
authorDaniel J Walsh <dwalsh@redhat.com>2018-02-22 14:34:08 -0500
committerDaniel J Walsh <dwalsh@redhat.com>2018-02-22 14:34:08 -0500
commit3602a57e9652eaf2454405d4771d1725cf7b111f (patch)
tree8dc547e40c82ff062f2dc8951bf6be91eb0f7045 /buildah.spec
parent71edb442dbb62e33ee10bfa8a64386ebcf0fe427 (diff)
downloadbuildah-3602a57e9652eaf2454405d4771d1725cf7b111f.tar.gz
buildah-3602a57e9652eaf2454405d4771d1725cf7b111f.tar.xz
buildah-3602a57e9652eaf2454405d4771d1725cf7b111f.zip
Vendor in latest containers/storage
This fixes a large SELinux bug. run: do not open /etc/hosts if not needed Add the following flags to buildah bud and from --add-host --cgroup-parent --cpu-period --cpu-quota --cpu-shares --cpuset-cpus --cpuset-mems --memory --memory-swap --security-opt --ulimit
Diffstat (limited to 'buildah.spec')
-rw-r--r--buildah.spec21
1 files changed, 19 insertions, 2 deletions
diff --git a/buildah.spec b/buildah.spec
index 0c6799f..51684ca 100644
--- a/buildah.spec
+++ b/buildah.spec
@@ -14,11 +14,11 @@
# https://github.com/projectatomic/buildah
%global provider_prefix %{provider}.%{provider_tld}/%{project}/%{repo}
%global import_path %{provider_prefix}
-%global commit 8badcc2d0229fde5ef3597c1066576fe8a638e7d
+%global commit ef0ca9cd2d69e8ca70d07e19386c676ae4985644
%global shortcommit %(c=%{commit}; echo ${c:0:7})
Name: %{repo}
-Version: 0.12
+Version: 0.13
Release: 1.git%{shortcommit}%{?dist}
Summary: A command line tool used for creating OCI Images
License: ASL 2.0
@@ -84,6 +84,23 @@ make DESTDIR=%{buildroot} PREFIX=%{_prefix} install install.completions
%{_datadir}/bash-completion/completions/%{name}
%changelog
+* Thu Feb 22 2018 Dan Walsh <dwalsh@redhat.com> 0.13-1
+- Vendor in latest containers/storage
+- This fixes a large SELinux bug.
+- run: do not open /etc/hosts if not needed
+- Add the following flags to buildah bud and from
+ --add-host
+ --cgroup-parent
+ --cpu-period
+ --cpu-quota
+ --cpu-shares
+ --cpuset-cpus
+ --cpuset-mems
+ --memory
+ --memory-swap
+ --security-opt
+ --ulimit
+
* Mon Feb 12 2018 Dan Walsh <dwalsh@redhat.com> 0.12-1
- Added handing for simpler error message for Unknown Dockerfile instructions.
- Change default certs directory to /etc/containers/certs.dir