summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorPeter Rajnoha <prajnoha@redhat.com>2009-09-11 15:55:07 +0000
committerPeter Rajnoha <prajnoha@redhat.com>2009-09-11 15:55:07 +0000
commitfd8563328c4109529383babb0d7518ee6e49ba04 (patch)
tree2354f8e53169b37f5271cb11f2873179850d88f8 /configure.in
parent9a9026c29fea71cdfab5e0575396906445805c69 (diff)
downloadlvm2-fd8563328c4109529383babb0d7518ee6e49ba04.tar.gz
lvm2-fd8563328c4109529383babb0d7518ee6e49ba04.tar.xz
lvm2-fd8563328c4109529383babb0d7518ee6e49ba04.zip
Add libudev configuration check.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index cc461cf6..52545907 100644
--- a/configure.in
+++ b/configure.in
@@ -651,6 +651,20 @@ UDEV_RULES=$enableval, UDEV_RULES=$UDEV_SYNC)
AC_MSG_RESULT($UDEV_RULES)
################################################################################
+dnl -- Check for libudev's udev_queue_get_udev_is_active function when udev synchronisation is enabled
+
+if test x$UDEV_SYNC = xyes; then
+ AC_CHECK_LIB(udev, udev_queue_get_udev_is_active, HAVE_UDEV_QUEUE_GET_UDEV_IS_ACTIVE=yes,
+ HAVE_UDEV_QUEUE_GET_UDEV_IS_ACTIVE=no)
+
+ if test x$HAVE_UDEV_QUEUE_GET_UDEV_IS_ACTIVE = xyes; then
+ AC_DEFINE([HAVE_UDEV_QUEUE_GET_UDEV_IS_ACTIVE], 1,
+ [Define to 1 if libudev's udev_queue_get_udev_is_active function is available.])
+ LIBS="-ludev $LIBS"
+ fi
+fi
+
+################################################################################
dnl -- Compatibility mode
AC_ARG_ENABLE(compat, [ --enable-compat Enable support for old device-mapper versions],
DM_COMPAT=$enableval, DM_COMPAT=no)