summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorZdenek Kabelac <zkabelac@redhat.com>2012-03-14 17:09:00 +0000
committerZdenek Kabelac <zkabelac@redhat.com>2012-03-14 17:09:00 +0000
commitf61cacad1604eaaef18389a46b07e35eb1072008 (patch)
tree932e03300022a858679239936a7aacdafae73f4e /configure.in
parent93945bb6160b333a48b089977436356bfb5948e0 (diff)
downloadlvm2-f61cacad1604eaaef18389a46b07e35eb1072008.tar.gz
lvm2-f61cacad1604eaaef18389a46b07e35eb1072008.tar.xz
lvm2-f61cacad1604eaaef18389a46b07e35eb1072008.zip
Add --with-thin-check configure option
If specified - use given path without test (Path could be empty) If autodetection is in use - check for command in available PATH.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c056984d..1a4bdeb1 100644
--- a/configure.in
+++ b/configure.in
@@ -411,6 +411,24 @@ case "$THIN" in
*) AC_MSG_ERROR([--with-thin parameter invalid ($THIN)]) ;;
esac
+case "$THIN" in
+ internal|shared)
+ AC_ARG_WITH(thin-check,
+ AC_HELP_STRING([--with-thin-check=PATH],
+ [thin_check tool: [[autodetect]]]),
+ THIN_CHECK_CMD=$withval, THIN_CHECK_CMD="autodetect")
+ # Empty means a config way to ignore thin checking
+ if test "$THIN_CHECK_CMD" = "autodetect"; then
+ AC_PATH_PROG(THIN_CHECK_CMD, thin_check)
+ test -z "$THIN_CHECK_CMD" && AC_MSG_ERROR(thin_check not found in path $PATH)
+ fi
+
+ AC_DEFINE_UNQUOTED([THIN_CHECK_CMD], ["$THIN_CHECK_CMD"],
+ [The path to 'thin_check', if available.])
+ ;;
+esac
+
+
################################################################################
dnl -- Disable readline
AC_MSG_CHECKING(whether to enable readline)
@@ -1475,6 +1493,7 @@ AC_SUBST(STATICDIR)
AC_SUBST(STATIC_LINK)
AC_SUBST(TESTING)
AC_SUBST(THIN)
+AC_SUBST(THIN_CHECK_CMD)
AC_SUBST(UDEV_LIBS)
AC_SUBST(UDEV_PC)
AC_SUBST(UDEV_RULES)