summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlasdair Kergon <agk@redhat.com>2009-10-05 12:11:30 +0000
committerAlasdair Kergon <agk@redhat.com>2009-10-05 12:11:30 +0000
commite1b8a236b7f340af9b3a54a578718955ce876558 (patch)
tree3e77b1d54a6080e99eadde26cd2809b7f107e67b /configure.in
parentdb8b5af9d94f537b6e9c9483c2bde06ac9edb621 (diff)
downloadlvm2-e1b8a236b7f340af9b3a54a578718955ce876558.tar.gz
lvm2-e1b8a236b7f340af9b3a54a578718955ce876558.tar.xz
lvm2-e1b8a236b7f340af9b3a54a578718955ce876558.zip
Only include selinux libs in libdevmapper.pc when selinux build enabled.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index bf360ed1..b4e7f28b 100644
--- a/configure.in
+++ b/configure.in
@@ -841,17 +841,18 @@ if test x$SELINUX = xyes; then
if test x$HAVE_SEPOL = xyes; then
AC_DEFINE([HAVE_SEPOL], 1,
[Define to 1 if sepol_check_context is available.])
- LIBS="-lsepol $LIBS"
+ SELINUX_LIBS="-lsepol $SELINUX_LIBS"
fi
AC_CHECK_LIB(selinux, is_selinux_enabled, HAVE_SELINUX=yes, HAVE_SELINUX=no)
if test x$HAVE_SELINUX = xyes; then
AC_DEFINE([HAVE_SELINUX], 1, [Define to 1 to include support for selinux.])
- LIBS="-lselinux $LIBS"
+ SELINUX_LIBS="-lselinux $SELINUX_LIBS"
else
AC_MSG_WARN(Disabling selinux)
fi
+ LIBS="$SELINUX_LIBS $LIBS"
# With --enable-static_link and selinux enabled, linking
# fails on at least Debian unstable due to unsatisfied references
@@ -1126,6 +1127,7 @@ AC_SUBST(SACKPT_CFLAGS)
AC_SUBST(SACKPT_LIBS)
AC_SUBST(SALCK_CFLAGS)
AC_SUBST(SALCK_LIBS)
+AC_SUBST(SELINUX_LIBS)
AC_SUBST(SNAPSHOTS)
AC_SUBST(STATICDIR)
AC_SUBST(STATIC_LINK)