summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorZdenek Kabelac <zkabelac@redhat.com>2010-03-04 12:12:34 +0000
committerZdenek Kabelac <zkabelac@redhat.com>2010-03-04 12:12:34 +0000
commitdb724a449b8a6325e81d04e835f7e24a35f9e78b (patch)
tree4077d40a1cf96f9eedff2e5ef5ada4c6b56f79bd /configure.in
parent19a2c6e0a745fca24e4dfa7b93a88d10af340c98 (diff)
downloadlvm2-db724a449b8a6325e81d04e835f7e24a35f9e78b.tar.gz
lvm2-db724a449b8a6325e81d04e835f7e24a35f9e78b.tar.xz
lvm2-db724a449b8a6325e81d04e835f7e24a35f9e78b.zip
Use UDEV_LIBS, and link -ludev only when needed.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index f6324202..3473d953 100644
--- a/configure.in
+++ b/configure.in
@@ -668,8 +668,9 @@ if test x$UDEV_SYNC = xyes; then
if test x$HAVE_UDEV_QUEUE_GET_UDEV_IS_ACTIVE = xyes; then
AC_DEFINE([HAVE_UDEV_QUEUE_GET_UDEV_IS_ACTIVE], 1,
[Define to 1 if libudev's udev_queue_get_udev_is_active function is available.])
- LIBS="-ludev $LIBS"
+ UDEV_LIBS="-ludev"
else
+ UDEV_LIBS=
AC_MSG_WARN(It won't be possible to get udev state. We will assume that udev is not running.)
fi
fi
@@ -1120,6 +1121,7 @@ AC_SUBST(SELINUX_LIBS)
AC_SUBST(SNAPSHOTS)
AC_SUBST(STATICDIR)
AC_SUBST(STATIC_LINK)
+AC_SUBST(UDEV_LIBS)
AC_SUBST(UDEV_RULES)
AC_SUBST(UDEV_SYNC)
AC_SUBST(interface)