summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJonathan Earl Brassow <jbrassow@redhat.com>2011-08-02 22:07:20 +0000
committerJonathan Earl Brassow <jbrassow@redhat.com>2011-08-02 22:07:20 +0000
commitcac52ca4ce125a5815121944995c0cdd752dec7e (patch)
treeb8b5e34ee23c4af2034ccfcd9a23c9cd5a0c1083 /configure.in
parentc212019f3ac76d8b8e3f2afcda45fcf7ca9d9656 (diff)
downloadlvm2-cac52ca4ce125a5815121944995c0cdd752dec7e.tar.gz
lvm2-cac52ca4ce125a5815121944995c0cdd752dec7e.tar.xz
lvm2-cac52ca4ce125a5815121944995c0cdd752dec7e.zip
Add basic RAID segment type(s) support.
Implementation described in doc/lvm2-raid.txt. Basic support includes: - ability to create RAID 1/4/5/6 arrays - ability to delete RAID arrays - ability to display RAID arrays Notable missing features (not included in this patch): - ability to clean-up/repair failures - ability to convert RAID segment types - ability to monitor RAID segment types
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 24 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index d54d7d80..24f1ec48 100644
--- a/configure.in
+++ b/configure.in
@@ -341,6 +341,26 @@ if test x$MIRRORS = xinternal; then
fi
################################################################################
+dnl -- raid inclusion type
+AC_MSG_CHECKING(whether to include raid)
+AC_ARG_WITH(raid,
+ AC_HELP_STRING([--with-raid=TYPE],
+ [mirror support: internal/shared/none
+ [[TYPE=internal]]]),
+ RAID=$withval, RAID=internal)
+AC_MSG_RESULT($RAID)
+
+if [[ "x$RAID" != xnone -a "x$RAID" != xinternal -a "x$RAID" != xshared ]];
+ then AC_MSG_ERROR(
+--with-raid parameter invalid
+)
+fi;
+
+if test x$RAID = xinternal; then
+ AC_DEFINE([RAID_INTERNAL], 1, [Define to 1 to include built-in support for raid.])
+fi
+
+################################################################################
dnl -- asynchronous volume replicator inclusion type
AC_MSG_CHECKING(whether to include replicators)
AC_ARG_WITH(replicators,
@@ -961,6 +981,7 @@ AC_CHECK_LIB(dl, dlopen, [
dnl -- Check for shared/static conflicts
if [[ \( "x$LVM1" = xshared -o "x$POOL" = xshared -o "x$CLUSTER" = xshared \
-o "x$SNAPSHOTS" = xshared -o "x$MIRRORS" = xshared \
+ -o "x$RAID" = xshared \
\) -a "x$STATIC_LINK" = xyes ]];
then AC_MSG_ERROR(
Features cannot be 'shared' when building statically
@@ -1346,16 +1367,17 @@ AC_SUBST(LVM_PATCHLEVEL)
AC_SUBST(LVM_RELEASE)
AC_SUBST(LVM_RELEASE_DATE)
AC_SUBST(MIRRORS)
+AC_SUBST(MSGFMT)
AC_SUBST(OCF)
AC_SUBST(OCFDIR)
-AC_SUBST(REPLICATORS)
-AC_SUBST(MSGFMT)
AC_SUBST(PKGCONFIG)
AC_SUBST(POOL)
AC_SUBST(PTHREAD_LIBS)
AC_SUBST(QUORUM_CFLAGS)
AC_SUBST(QUORUM_LIBS)
+AC_SUBST(RAID)
AC_SUBST(READLINE_LIBS)
+AC_SUBST(REPLICATORS)
AC_SUBST(SACKPT_CFLAGS)
AC_SUBST(SACKPT_LIBS)
AC_SUBST(SALCK_CFLAGS)