summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlasdair Kergon <agk@redhat.com>2011-11-14 21:30:35 +0000
committerAlasdair Kergon <agk@redhat.com>2011-11-14 21:30:35 +0000
commitbf09a32006570e16c28fc3002f770b6e41a2788a (patch)
tree01c3f4739905a8e89daccecfd0e63c3c8db66459 /configure.in
parent2ce5ca43753fa164e1dd12aea7643d493b4c89cc (diff)
downloadlvm2-bf09a32006570e16c28fc3002f770b6e41a2788a.tar.gz
lvm2-bf09a32006570e16c28fc3002f770b6e41a2788a.tar.xz
lvm2-bf09a32006570e16c28fc3002f770b6e41a2788a.zip
Make dmsetup.static and lvm.static build when dmeventd is disabled.
udev may also need to be disabled if you didn't build it statically too. dmeventd.static could be fixed with some more work but I don't really see the point: without dlopen() it's useless, and if you have dlopen(), why not support normal shared libraries too?
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 5275b950..e06390a7 100644
--- a/configure.in
+++ b/configure.in
@@ -31,10 +31,11 @@ case "$host_os" in
CFLAGS="$CFLAGS"
COPTIMISE_FLAG="-O2"
CLDFLAGS="$CLDFLAGS -Wl,--version-script,.export.sym"
+ ELDFLAGS="-Wl,--export-dynamic"
+ # FIXME Generate list and use --dynamic-list=.dlopen.sym
CLDWHOLEARCHIVE="-Wl,-whole-archive"
CLDNOWHOLEARCHIVE="-Wl,-no-whole-archive"
LDDEPS="$LDDEPS .export.sym"
- LDFLAGS="$LDFLAGS -Wl,--export-dynamic"
LIB_SUFFIX=so
DEVMAPPER=yes
LVMETAD=no
@@ -48,6 +49,7 @@ case "$host_os" in
CFLAGS="$CFLAGS -no-cpp-precomp -fno-common"
COPTIMISE_FLAG="-O2"
CLDFLAGS="$CLDFLAGS"
+ ELDFLAGS=
CLDWHOLEARCHIVE="-all_load"
CLDNOWHOLEARCHIVE=
LIB_SUFFIX=dylib
@@ -1342,6 +1344,7 @@ AC_SUBST(DM_DEVICE_UID)
AC_SUBST(DM_IOCTLS)
AC_SUBST(DM_LIB_VERSION)
AC_SUBST(DM_LIB_PATCHLEVEL)
+AC_SUBST(ELDFLAGS)
AC_SUBST(FSADM)
AC_SUBST(HAVE_LIBDL)
AC_SUBST(HAVE_REALTIME)