summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorPeter Rajnoha <prajnoha@redhat.com>2012-02-20 19:36:27 +0000
committerPeter Rajnoha <prajnoha@redhat.com>2012-02-20 19:36:27 +0000
commitb559a1e6f0ce94a74d962847f70c8e831e07b030 (patch)
treebfb3467ed38365e9d9301169129625c3aafd71b3 /configure.in
parent36c90588fc05043820a88a1bc5b201966db885fb (diff)
downloadlvm2-b559a1e6f0ce94a74d962847f70c8e831e07b030.tar.gz
lvm2-b559a1e6f0ce94a74d962847f70c8e831e07b030.tar.xz
lvm2-b559a1e6f0ce94a74d962847f70c8e831e07b030.zip
Check whether udev supports built-in blkid.
Built-in blkid is supported since udev v176 - set the UDEV_HAS_BUILTIN_BLKID variable appropriately so we can use it in the rules to call the built-in blkid conditionaly.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 784cfa1c..cfa80170 100644
--- a/configure.in
+++ b/configure.in
@@ -873,6 +873,17 @@ AC_ARG_ENABLE(udev_rules,
UDEV_RULES=$enableval, UDEV_RULES=$UDEV_SYNC)
AC_MSG_RESULT($UDEV_RULES)
+if test x$UDEV_RULES = xyes; then
+ AC_MSG_CHECKING(whether udev supports builtin blkid)
+ udev_version=$(udevadm info --version 2>/dev/null)
+ if test -n "$udev_version" && test "$udev_version" -ge 176; then
+ UDEV_HAS_BUILTIN_BLKID=yes
+ else
+ UDEV_HAS_BUILTIN_BLKID=no
+ fi
+ AC_MSG_RESULT($UDEV_HAS_BUILTIN_BLKID)
+fi
+
################################################################################
dnl -- Compatibility mode
AC_ARG_ENABLE(compat,
@@ -1454,6 +1465,7 @@ AC_SUBST(UDEV_LIBS)
AC_SUBST(UDEV_PC)
AC_SUBST(UDEV_RULES)
AC_SUBST(UDEV_SYNC)
+AC_SUBST(UDEV_HAS_BUILTIN_BLKID)
AC_SUBST(CUNIT_LIBS)
AC_SUBST(CUNIT_CFLAGS)
AC_SUBST(WRITE_INSTALL)