summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorZdenek Kabelac <zkabelac@redhat.com>2011-11-21 10:40:21 +0000
committerZdenek Kabelac <zkabelac@redhat.com>2011-11-21 10:40:21 +0000
commit9493f1df09c5a935767ecafb46f2f65aecca6c97 (patch)
treeeba4e52f37664230f08201ccdc564fb854e41fd1 /configure.in
parentf2a3f0fe3dfb34b9d7344fae51083c392cfba8a8 (diff)
downloadlvm2-9493f1df09c5a935767ecafb46f2f65aecca6c97.tar.gz
lvm2-9493f1df09c5a935767ecafb46f2f65aecca6c97.tar.xz
lvm2-9493f1df09c5a935767ecafb46f2f65aecca6c97.zip
Add CUnit testing support
Regenerate configure for unit test support.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index eccd44f2..0fb5a069 100644
--- a/configure.in
+++ b/configure.in
@@ -759,11 +759,10 @@ AC_ARG_ENABLE(testing,
AC_MSG_RESULT($TESTING)
if test "$TESTING" = yes; then
- AC_PATH_PROG(RUBY19, ruby1.9)
- AC_PATH_PROG(VALGRIND, valgrind)
- if test -z "$RUBY19" -o -z "$VALGRIND"; then
- AC_MSG_ERROR([ruby1.9 and valgrind are required for testing])
- fi
+ AC_CHECK_HEADER([CUnit/Basic.h], have_cunit=yes, have_cunit=no)
+ if test "$have_cunit" = "no"; then
+ AC_MSG_ERROR([CUnit is required for unit testing])
+ fi
fi
################################################################################