summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlasdair Kergon <agk@redhat.com>2009-09-14 22:57:46 +0000
committerAlasdair Kergon <agk@redhat.com>2009-09-14 22:57:46 +0000
commit90c8088760d5fd46ad9f5edb58482a491be53f26 (patch)
treef2177769fd956e2ce9211996ce16e6186f2ad6c9 /configure.in
parenta4cc1ef5d9102446be9c9792063f633fdfbd107c (diff)
downloadlvm2-90c8088760d5fd46ad9f5edb58482a491be53f26.tar.gz
lvm2-90c8088760d5fd46ad9f5edb58482a491be53f26.tar.xz
lvm2-90c8088760d5fd46ad9f5edb58482a491be53f26.zip
More cmirror makefile fixes from Fabio.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in43
1 files changed, 27 insertions, 16 deletions
diff --git a/configure.in b/configure.in
index 52545907..e22f0db8 100644
--- a/configure.in
+++ b/configure.in
@@ -322,6 +322,17 @@ REALTIME=$enableval)
AC_MSG_RESULT($REALTIME)
################################################################################
+dnl -- Init pkg-config with dummy invokation:
+dnl -- this is required because PKG_CHECK_MODULES macro is expanded
+dnl -- to initialize the pkg-config environment only at the first invokation,
+dnl -- that would be conditional in this configure.in.
+pkg_config_init() {
+ PKG_CHECK_MODULES(PKGCONFIGINIT, pkgconfiginit, [],
+ [AC_MSG_RESULT([pkg-config initialized])])
+ PKGCONFIG_INIT=1
+}
+
+################################################################################
dnl -- Build cluster LVM daemon
AC_MSG_CHECKING(whether to build cluster LVM daemon)
AC_ARG_WITH(clvmd,
@@ -345,6 +356,12 @@ if test x$CLVMD != xnone && test x$CLUSTER = xnone; then
CLUSTER=internal
fi
+dnl -- init pkgconfig if required
+if test x$CLVMD != xnone && test x$PKGCONFIG_INIT != x1; then
+ pkg_config_init
+fi
+
+
dnl -- define build types
if [[ `expr x"$CLVMD" : '.*gulm.*'` != 0 ]]; then
BUILDGULM=yes
@@ -367,15 +384,6 @@ if test x$BUILDGULM = xyes; then
fi
fi
-dnl -- Init pkg-config with dummy invokation:
-dnl -- this is required because PKG_CHECK_MODULES macro is expanded
-dnl -- to initialize the pkg-config environment only at the first invokation,
-dnl -- that would be conditional in this configure.in.
-if test x$CLVMD != xnone; then
- PKG_CHECK_MODULES(PKGCONFIGINIT, pkgconfiginit, [],
- [AC_MSG_RESULT([pkg-config initialized])])
-fi
-
dnl -- define a soft bailout if we are autodetecting
soft_bailout() {
NOTFOUND=1
@@ -574,13 +582,14 @@ fi
################################################################################
dnl -- Look for corosync libraries if required.
if [[ "x$BUILD_CMIRRORD" = xyes ]]; then
-#
-# FIXME: ALSO NEED TO CHECK FOR CHECKPOINT MODULE
-# FIXME: Merge this with the new clvmd logic
-#
- PKG_CHECK_MODULES(CPG, libcpg, [],
- [AC_MSG_RESULT([no pkg for libcpg library, using -lcpg]);
- CPG_LIBS="-lcpg"])
+ dnl -- init pkgconfig if required
+ if test x$PKGCONFIG_INIT != x1; then
+ pkg_config_init
+ fi
+ PKG_CHECK_MODULES(SACKPT, libSaCkpt)
+ if test x$HAVE_CPG != xyes; then
+ PKG_CHECK_MODULES(CPG, libcpg)
+ fi
fi
################################################################################
@@ -1101,6 +1110,8 @@ AC_SUBST(PKGCONFIG)
AC_SUBST(POOL)
AC_SUBST(QUORUM_CFLAGS)
AC_SUBST(QUORUM_LIBS)
+AC_SUBST(SACKPT_CFLAGS)
+AC_SUBST(SACKPT_LIBS)
AC_SUBST(SALCK_CFLAGS)
AC_SUBST(SALCK_LIBS)
AC_SUBST(SNAPSHOTS)