summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorFabio M. Di Nitto <fdinitto@redhat.com>2010-07-13 13:51:01 +0000
committerFabio M. Di Nitto <fdinitto@redhat.com>2010-07-13 13:51:01 +0000
commit8c4e8a185a371ee6133168603890bfa923163f88 (patch)
tree0200fb53a4edf74f7ec6a9ee6dd2c12b29df8aa7 /configure.in
parent8e3da446f4d81f693ead821db6cf1ca837ab19fc (diff)
downloadlvm2-8c4e8a185a371ee6133168603890bfa923163f88.tar.gz
lvm2-8c4e8a185a371ee6133168603890bfa923163f88.tar.xz
lvm2-8c4e8a185a371ee6133168603890bfa923163f88.zip
Add dm_create_lockfile to libdm to handle pidfiles for all daemons.
Switch dmeventd to use dm_create_lockfile and drop duplicate code. Allow clvmd pidfile to be configurable. Switch cmirrord and clvmd to use dm_create_lockfile.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 439444f1..6b5d65a3 100644
--- a/configure.in
+++ b/configure.in
@@ -601,6 +601,18 @@ if test x$CLVMD = xall; then
fi
################################################################################
+dnl -- clvmd pidfile
+if test "x$CLVMD" != xnone; then
+ AC_ARG_WITH(clvmd-pidfile,
+ AC_HELP_STRING([--with-clvmd-pidfile=PATH],
+ [clvmd pidfile [[/var/run/clvmd.pid]]]),
+ CLVMD_PIDFILE=$withval,
+ CLVMD_PIDFILE="/var/run/clvmd.pid")
+ AC_DEFINE_UNQUOTED(CLVMD_PIDFILE, ["$CLVMD_PIDFILE"],
+ [Path to clvmd pidfile.])
+fi
+
+################################################################################
dnl -- Build cluster mirror log daemon
AC_MSG_CHECKING(whether to build cluster mirror log daemon)
AC_ARG_ENABLE(cmirrord,