summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorZdenek Kabelac <zkabelac@redhat.com>2010-07-08 12:02:48 +0000
committerZdenek Kabelac <zkabelac@redhat.com>2010-07-08 12:02:48 +0000
commit71082be43a893b6edc2a8a9dba6e45c11020e11f (patch)
tree4cac33c9d6ef386694fe2fa968e498353cf27a2a /configure.in
parent69e80c9eee917ff6ea99d22c74ac0ebf80ab0f56 (diff)
downloadlvm2-71082be43a893b6edc2a8a9dba6e45c11020e11f.tar.gz
lvm2-71082be43a893b6edc2a8a9dba6e45c11020e11f.tar.xz
lvm2-71082be43a893b6edc2a8a9dba6e45c11020e11f.zip
Cleanups for configure:
Indent updates. Use AC_HELP_STRING for help string. Start help string with lower letter. Add [] around some default values i.e. [TYPE=internal]. Skip some "" around shell assigment when not needed. Fix typo --with-device-gid=UID string.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in335
1 files changed, 188 insertions, 147 deletions
diff --git a/configure.in b/configure.in
index a8a5b92c..439444f1 100644
--- a/configure.in
+++ b/configure.in
@@ -148,9 +148,10 @@ AC_FUNC_VPRINTF
dnl -- Enables statically-linked tools
AC_MSG_CHECKING(whether to use static linking)
AC_ARG_ENABLE(static_link,
- [ --enable-static_link Use this to link the tools to their libraries
- statically. Default is dynamic linking],
- STATIC_LINK=$enableval, STATIC_LINK=no)
+ AC_HELP_STRING([--enable-static_link],
+ [use this to link the tools to their libraries
+ statically (default is dynamic linking]),
+ STATIC_LINK=$enableval, STATIC_LINK=no)
AC_MSG_RESULT($STATIC_LINK)
################################################################################
@@ -161,8 +162,9 @@ AC_PREFIX_DEFAULT(/usr)
dnl -- Setup the ownership of the files
AC_MSG_CHECKING(file owner)
AC_ARG_WITH(user,
- [ --with-user=USER Set the owner of installed files [[USER=]] ],
- [ OWNER="$withval" ])
+ AC_HELP_STRING([--with-user=USER],
+ [set the owner of installed files [[USER=]]]),
+ OWNER=$withval)
AC_MSG_RESULT($OWNER)
if test x$OWNER != x; then
@@ -173,8 +175,9 @@ fi
dnl -- Setup the group ownership of the files
AC_MSG_CHECKING(group owner)
AC_ARG_WITH(group,
- [ --with-group=GROUP Set the group owner of installed files [[GROUP=]] ],
- [ GROUP="$withval" ])
+ AC_HELP_STRING([--with-group=GROUP],
+ [set the group owner of installed files [[GROUP=]]]),
+ GROUP=$withval)
AC_MSG_RESULT($GROUP)
if test x$GROUP != x; then
@@ -186,8 +189,9 @@ dnl -- Setup device node ownership
AC_MSG_CHECKING(device node uid)
AC_ARG_WITH(device-uid,
- [ --with-device-uid=UID Set the owner used for new device nodes [[UID=0]] ],
- [ DM_DEVICE_UID="$withval" ], [ DM_DEVICE_UID="0" ] )
+ AC_HELP_STRING([--with-device-uid=UID],
+ [set the owner used for new device nodes [[UID=0]]]),
+ DM_DEVICE_UID=$withval, DM_DEVICE_UID=0)
AC_MSG_RESULT($DM_DEVICE_UID)
################################################################################
@@ -195,8 +199,9 @@ dnl -- Setup device group ownership
AC_MSG_CHECKING(device node gid)
AC_ARG_WITH(device-gid,
- [ --with-device-gid=UID Set the group used for new device nodes [[GID=0]] ],
- [ DM_DEVICE_GID="$withval" ], [ DM_DEVICE_GID="0" ] )
+ AC_HELP_STRING([--with-device-gid=GID],
+ [set the group used for new device nodes [[GID=0]]]),
+ DM_DEVICE_GID=$withval, DM_DEVICE_GID=0)
AC_MSG_RESULT($DM_DEVICE_GID)
################################################################################
@@ -204,15 +209,19 @@ dnl -- Setup device mode
AC_MSG_CHECKING(device node mode)
AC_ARG_WITH(device-mode,
- [ --with-device-mode=MODE Set the mode used for new device nodes [[MODE=0600]] ],
- [ DM_DEVICE_MODE="$withval" ], [ DM_DEVICE_MODE="0600" ] )
+ AC_HELP_STRING([--with-device-mode=MODE],
+ [set the mode used for new device nodes [[MODE=0600]]]),
+ DM_DEVICE_MODE=$withval, DM_DEVICE_MODE=0600)
AC_MSG_RESULT($DM_DEVICE_MODE)
################################################################################
dnl -- LVM1 tool fallback option
AC_MSG_CHECKING(whether to enable lvm1 fallback)
-AC_ARG_ENABLE(lvm1_fallback, [ --enable-lvm1_fallback Use this to fall back and use LVM1 binaries if
- device-mapper is missing from the kernel], LVM1_FALLBACK=$enableval, LVM1_FALLBACK=no)
+AC_ARG_ENABLE(lvm1_fallback,
+ AC_HELP_STRING([--enable-lvm1_fallback],
+ [use this to fall back and use LVM1 binaries if
+ device-mapper is missing from the kernel]),
+ LVM1_FALLBACK=$enableval, LVM1_FALLBACK=no)
AC_MSG_RESULT($LVM1_FALLBACK)
if test x$LVM1_FALLBACK = xyes; then
@@ -223,10 +232,10 @@ fi
dnl -- format1 inclusion type
AC_MSG_CHECKING(whether to include support for lvm1 metadata)
AC_ARG_WITH(lvm1,
- [ --with-lvm1=TYPE LVM1 metadata support: internal/shared/none
- [TYPE=internal] ],
- [ LVM1="$withval" ],
- [ LVM1="internal" ])
+ AC_HELP_STRING([--with-lvm1=TYPE],
+ [LVM1 metadata support: internal/shared/none
+ [[TYPE=internal]]]),
+ LVM1=$withval, LVM1=internal)
AC_MSG_RESULT($LVM1)
if [[ "x$LVM1" != xnone -a "x$LVM1" != xinternal -a "x$LVM1" != xshared ]];
@@ -243,10 +252,10 @@ fi
dnl -- format_pool inclusion type
AC_MSG_CHECKING(whether to include support for GFS pool metadata)
AC_ARG_WITH(pool,
- [ --with-pool=TYPE GFS pool read-only support: internal/shared/none
- [TYPE=internal] ],
- [ POOL="$withval" ],
- [ POOL="internal" ])
+ AC_HELP_STRING([--with-pool=TYPE],
+ [GFS pool read-only support: internal/shared/none
+ [[TYPE=internal]]]),
+ POOL=$withval, POOL=internal)
AC_MSG_RESULT($POOL)
if [[ "x$POOL" != xnone -a "x$POOL" != xinternal -a "x$POOL" != xshared ]];
@@ -263,9 +272,10 @@ fi
dnl -- cluster_locking inclusion type
AC_MSG_CHECKING(whether to include support for cluster locking)
AC_ARG_WITH(cluster,
- [ --with-cluster=TYPE Cluster LVM locking support: internal/shared/none
- [TYPE=internal] ],
- [ CLUSTER="$withval" ])
+ AC_HELP_STRING([--with-cluster=TYPE],
+ [cluster LVM locking support: internal/shared/none
+ [[TYPE=internal]]]),
+ CLUSTER=$withval)
AC_MSG_RESULT($CLUSTER)
if [[ "x$CLUSTER" != xnone -a "x$CLUSTER" != xinternal -a "x$CLUSTER" != xshared ]];
@@ -282,10 +292,10 @@ fi
dnl -- snapshots inclusion type
AC_MSG_CHECKING(whether to include snapshots)
AC_ARG_WITH(snapshots,
- [ --with-snapshots=TYPE Snapshot support: internal/shared/none
- [TYPE=internal] ],
- [ SNAPSHOTS="$withval" ],
- [ SNAPSHOTS="internal" ])
+ AC_HELP_STRING([--with-snapshots=TYPE],
+ [snapshot support: internal/shared/none
+ [[TYPE=internal]]]),
+ SNAPSHOTS=$withval, SNAPSHOTS=internal)
AC_MSG_RESULT($SNAPSHOTS)
if [[ "x$SNAPSHOTS" != xnone -a "x$SNAPSHOTS" != xinternal -a "x$SNAPSHOTS" != xshared ]];
@@ -302,10 +312,10 @@ fi
dnl -- mirrors inclusion type
AC_MSG_CHECKING(whether to include mirrors)
AC_ARG_WITH(mirrors,
- [ --with-mirrors=TYPE Mirror support: internal/shared/none
- [TYPE=internal] ],
- [ MIRRORS="$withval" ],
- [ MIRRORS="internal" ])
+ AC_HELP_STRING([--with-mirrors=TYPE],
+ [mirror support: internal/shared/none
+ [[TYPE=internal]]]),
+ MIRRORS=$withval, MIRRORS=internal)
AC_MSG_RESULT($MIRRORS)
if [[ "x$MIRRORS" != xnone -a "x$MIRRORS" != xinternal -a "x$MIRRORS" != xshared ]];
@@ -321,9 +331,11 @@ fi
################################################################################
dnl -- asynchronous volume replicator inclusion type
AC_MSG_CHECKING(whether to include replicators)
-AC_ARG_WITH(replicators, AC_HELP_STRING([--with-replicators=TYPE],
- [Replicator support: internal/shared/none [TYPE=none] ]),
- [REPLICATORS=$withval], [REPLICATORS="none"])
+AC_ARG_WITH(replicators,
+ AC_HELP_STRING([--with-replicators=TYPE],
+ [replicator support: internal/shared/none
+ [[TYPE=none]]]),
+ REPLICATORS=$withval, REPLICATORS=none)
AC_MSG_RESULT($REPLICATORS)
case "$REPLICATORS" in
@@ -337,15 +349,16 @@ esac
dnl -- Disable readline
AC_MSG_CHECKING(whether to enable readline)
AC_ARG_ENABLE([readline],
- [ --disable-readline Disable readline support],
- [READLINE=$enableval], [READLINE=maybe])
+ AC_HELP_STRING([--disable-readline], [disable readline support]),
+ READLINE=$enableval, READLINE=maybe)
AC_MSG_RESULT($READLINE)
################################################################################
dnl -- Disable realtime clock support
AC_MSG_CHECKING(whether to enable realtime support)
-AC_ARG_ENABLE(realtime, [ --enable-realtime Enable realtime clock support],
-REALTIME=$enableval)
+AC_ARG_ENABLE(realtime,
+ AC_HELP_STRING([--enable-realtime], [enable realtime clock support]),
+ REALTIME=$enableval)
AC_MSG_RESULT($REALTIME)
################################################################################
@@ -363,7 +376,7 @@ pkg_config_init() {
dnl -- Build cluster LVM daemon
AC_MSG_CHECKING(whether to build cluster LVM daemon)
AC_ARG_WITH(clvmd,
- [ --with-clvmd=TYPE Build cluster LVM Daemon.
+ [ --with-clvmd=TYPE build cluster LVM Daemon
The following cluster manager combinations are valid:
* cman,gulm (RHEL4 or equivalent)
* cman (RHEL5 or equivalent)
@@ -371,9 +384,8 @@ AC_ARG_WITH(clvmd,
* singlenode (localhost only)
* all (autodetect)
* none (disable build)
- [TYPE=none] ],
- [ CLVMD="$withval" ],
- [ CLVMD="none" ])
+ [[TYPE=none]]],
+ CLVMD=$withval, CLVMD=none)
if test x$CLVMD = xyes; then
CLVMD=all
fi
@@ -591,20 +603,24 @@ fi
################################################################################
dnl -- Build cluster mirror log daemon
AC_MSG_CHECKING(whether to build cluster mirror log daemon)
-AC_ARG_ENABLE(cmirrord, [ --enable-cmirrord Enable the cluster mirror log daemon],
-CMIRRORD=$enableval, CMIRRORD=no)
+AC_ARG_ENABLE(cmirrord,
+ AC_HELP_STRING([--enable-cmirrord],
+ [enable the cluster mirror log daemon]),
+ CMIRRORD=$enableval, CMIRRORD=no)
AC_MSG_RESULT($CMIRRORD)
BUILD_CMIRRORD=$CMIRRORD
################################################################################
dnl -- cmirrord pidfile
-AH_TEMPLATE(CMIRRORD_PIDFILE, [Path to cmirrord pidfile.])
if test "x$BUILD_CMIRRORD" = xyes; then
AC_ARG_WITH(cmirrord-pidfile,
- [ --with-cmirrord-pidfile=PATH cmirrord pidfile [[/var/run/cmirrord.pid]] ],
- [ AC_DEFINE_UNQUOTED(CMIRRORD_PIDFILE,"$withval") ],
- [ AC_DEFINE_UNQUOTED(CMIRRORD_PIDFILE,"/var/run/cmirrord.pid") ])
+ AC_HELP_STRING([--with-cmirrord-pidfile=PATH],
+ [cmirrord pidfile [[/var/run/cmirrord.pid]]]),
+ CMIRRORD_PIDFILE=$withval,
+ CMIRRORD_PIDFILE="/var/run/cmirrord.pid")
+ AC_DEFINE_UNQUOTED(CMIRRORD_PIDFILE, ["$CMIRRORD_PIDFILE"],
+ [Path to cmirrord pidfile.])
fi
################################################################################
@@ -623,8 +639,8 @@ fi
################################################################################
dnl -- Enable debugging
AC_MSG_CHECKING(whether to enable debugging)
-AC_ARG_ENABLE(debug, [ --enable-debug Enable debugging],
- DEBUG=$enableval, DEBUG=no)
+AC_ARG_ENABLE(debug, AC_HELP_STRING([--enable-debug], [enable debugging]),
+ DEBUG=$enableval, DEBUG=no)
AC_MSG_RESULT($DEBUG)
dnl -- Normally turn off optimisation for debug builds
@@ -638,16 +654,17 @@ fi
dnl -- Override optimisation
AC_MSG_CHECKING(for C optimisation flag)
AC_ARG_WITH(optimisation,
- [ --with-optimisation=OPT C optimisation flag [[OPT=-O2]] ],
- [ COPTIMISE_FLAG="$withval" ])
+ AC_HELP_STRING([--with-optimisation=OPT],
+ [C optimisation flag [[OPT=-O2]]]),
+ COPTIMISE_FLAG=$withval)
AC_MSG_RESULT($COPTIMISE_FLAG)
################################################################################
dnl -- Enable profiling
AC_MSG_CHECKING(whether to gather gcov profiling data)
AC_ARG_ENABLE(profiling,
- AC_HELP_STRING(--enable-profiling, [Gather gcov profiling data]),
- PROFILING=$enableval, PROFILING=no)
+ AC_HELP_STRING(--enable-profiling, [gather gcov profiling data]),
+ PROFILING=$enableval, PROFILING=no)
AC_MSG_RESULT($PROFILING)
if test "x$PROFILING" = xyes; then
@@ -674,8 +691,10 @@ fi
################################################################################
dnl -- Disable devmapper
AC_MSG_CHECKING(whether to use device-mapper)
-AC_ARG_ENABLE(devmapper, [ --disable-devmapper Disable LVM2 device-mapper interaction],
-DEVMAPPER=$enableval)
+AC_ARG_ENABLE(devmapper,
+ AC_HELP_STRING([--disable-devmapper],
+ [disable LVM2 device-mapper interaction]),
+ DEVMAPPER=$enableval)
AC_MSG_RESULT($DEVMAPPER)
if test x$DEVMAPPER = xyes; then
@@ -685,8 +704,10 @@ fi
################################################################################
dnl -- Enable udev synchronisation
AC_MSG_CHECKING(whether to enable synchronisation with udev processing)
-AC_ARG_ENABLE(udev_sync, [ --enable-udev_sync Enable synchronisation with udev processing],
-UDEV_SYNC=$enableval, UDEV_SYNC=no)
+AC_ARG_ENABLE(udev_sync,
+ AC_HELP_STRING([--enable-udev_sync],
+ [enable synchronisation with udev processing]),
+ UDEV_SYNC=$enableval, UDEV_SYNC=no)
AC_MSG_RESULT($UDEV_SYNC)
if test x$UDEV_SYNC = xyes; then
@@ -698,21 +719,26 @@ fi
dnl -- Enable udev rules
AC_MSG_CHECKING(whether to enable installation of udev rules required for synchronisation)
-AC_ARG_ENABLE(udev_rules, [ --enable-udev_rules Install rule files needed for udev synchronisation],
-UDEV_RULES=$enableval, UDEV_RULES=$UDEV_SYNC)
+AC_ARG_ENABLE(udev_rules,
+ AC_HELP_STRING([--enable-udev_rules],
+ [install rule files needed for udev synchronisation]),
+ UDEV_RULES=$enableval, UDEV_RULES=$UDEV_SYNC)
AC_MSG_RESULT($UDEV_RULES)
################################################################################
dnl -- Compatibility mode
-AC_ARG_ENABLE(compat, [ --enable-compat Enable support for old device-mapper versions],
- DM_COMPAT=$enableval, DM_COMPAT=no)
+AC_ARG_ENABLE(compat,
+ AC_HELP_STRING([--enable-compat],
+ [enable support for old device-mapper versions]),
+ DM_COMPAT=$enableval, DM_COMPAT=no)
################################################################################
dnl -- Compatible units suffix mode
AC_ARG_ENABLE(units-compat,
- [ --enable-units-compat Enable output compatibility with old versions that
- that don't use KiB-style unit suffixes],
- UNITS_COMPAT=$enableval, UNITS_COMPAT=no)
+ AC_HELP_STRING([--enable-units-compat],
+ [enable output compatibility with old versions that
+ that do not use KiB-style unit suffixes]),
+ UNITS_COMPAT=$enableval, UNITS_COMPAT=no)
if test x$UNITS_COMPAT = xyes; then
AC_DEFINE([DEFAULT_SI_UNIT_CONSISTENCY], 0, [Define to 0 to reinstate the pre-2.02.54 handling of unit suffixes.])
@@ -720,14 +746,17 @@ fi
################################################################################
dnl -- Disable ioctl
-AC_ARG_ENABLE(ioctl, [ --disable-driver Disable calls to device-mapper in the kernel],
- DM_IOCTLS=$enableval)
+AC_ARG_ENABLE(ioctl,
+ AC_HELP_STRING([--disable-driver],
+ [disable calls to device-mapper in the kernel]),
+ DM_IOCTLS=$enableval)
################################################################################
dnl -- Disable O_DIRECT
AC_MSG_CHECKING(whether to enable O_DIRECT)
-AC_ARG_ENABLE(o_direct, [ --disable-o_direct Disable O_DIRECT],
-ODIRECT=$enableval)
+AC_ARG_ENABLE(o_direct,
+ AC_HELP_STRING([--disable-o_direct], [disable O_DIRECT]),
+ ODIRECT=$enableval)
AC_MSG_RESULT($ODIRECT)
if test x$ODIRECT = xyes; then
@@ -738,8 +767,8 @@ fi
dnl -- Enable liblvm2app.so
AC_MSG_CHECKING(whether to build liblvm2app.so application library)
AC_ARG_ENABLE(applib,
- [ --enable-applib Build application library],
- APPLIB=$enableval, APPLIB=no)
+ AC_HELP_STRING([--enable-applib], [build application library]),
+ APPLIB=$enableval, APPLIB=no)
AC_MSG_RESULT($APPLIB)
AC_SUBST([LVM2APP_LIB])
test x$APPLIB = xyes \
@@ -749,8 +778,9 @@ test x$APPLIB = xyes \
################################################################################
dnl -- Enable cmdlib
AC_MSG_CHECKING(whether to compile liblvm2cmd.so)
-AC_ARG_ENABLE(cmdlib, [ --enable-cmdlib Build shared command library],
-CMDLIB=$enableval, CMDLIB=no)
+AC_ARG_ENABLE(cmdlib,
+ AC_HELP_STRING([--enable-cmdlib], [build shared command library]),
+ CMDLIB=$enableval, CMDLIB=no)
AC_MSG_RESULT($CMDLIB)
AC_SUBST([LVM2CMD_LIB])
test x$CMDLIB = xyes \
@@ -759,27 +789,30 @@ test x$CMDLIB = xyes \
################################################################################
dnl -- Enable pkg-config
-AC_ARG_ENABLE(pkgconfig, [ --enable-pkgconfig Install pkgconfig support],
- PKGCONFIG=$enableval, PKGCONFIG=no)
+AC_ARG_ENABLE(pkgconfig,
+ AC_HELP_STRING([--enable-pkgconfig], [install pkgconfig support]),
+ PKGCONFIG=$enableval, PKGCONFIG=no)
################################################################################
dnl -- Enable installation of writable files by user
-AC_ARG_ENABLE(write_install, AC_HELP_STRING([--enable-write_install],
- [Install user writable files]),
- [WRITE_INSTALL=$enableval], [WRITE_INSTALL=no])
+AC_ARG_ENABLE(write_install,
+ AC_HELP_STRING([--enable-write_install],
+ [install user writable files]),
+ WRITE_INSTALL=$enableval, WRITE_INSTALL=no)
################################################################################
dnl -- Enable fsadm
AC_MSG_CHECKING(whether to install fsadm)
-AC_ARG_ENABLE(fsadm, [AC_HELP_STRING([--disable-fsadm], [Disable fsadm])],
- FSADM=$enableval)
+AC_ARG_ENABLE(fsadm, AC_HELP_STRING([--disable-fsadm], [disable fsadm]),
+ FSADM=$enableval)
AC_MSG_RESULT($FSADM)
################################################################################
dnl -- enable dmeventd handling
AC_MSG_CHECKING(whether to use dmeventd)
-AC_ARG_ENABLE(dmeventd, [ --enable-dmeventd Enable the device-mapper event daemon],
-DMEVENTD=$enableval)
+AC_ARG_ENABLE(dmeventd, AC_HELP_STRING([--enable-dmeventd],
+ [enable the device-mapper event daemon]),
+ DMEVENTD=$enableval)
AC_MSG_RESULT($DMEVENTD)
BUILD_DMEVENTD=$DMEVENTD
@@ -849,8 +882,9 @@ fi
################################################################################
dnl -- Disable selinux
AC_MSG_CHECKING(whether to enable selinux support)
-AC_ARG_ENABLE(selinux, [ --disable-selinux Disable selinux support],
- SELINUX=$enableval)
+AC_ARG_ENABLE(selinux,
+ AC_HELP_STRING([--disable-selinux], [disable selinux support]),
+ SELINUX=$enableval)
AC_MSG_RESULT($SELINUX)
################################################################################
@@ -935,8 +969,9 @@ fi
################################################################################
dnl -- Internationalisation stuff
AC_MSG_CHECKING(whether to enable internationalisation)
-AC_ARG_ENABLE(nls, [ --enable-nls Enable Native Language Support],
- INTL=$enableval, INTL=no)
+AC_ARG_ENABLE(nls,
+ AC_HELP_STRING([--enable-nls], [enable Native Language Support]),
+ INTL=$enableval, INTL=no)
AC_MSG_RESULT($INTL)
if test x$INTL = xyes; then
@@ -950,42 +985,43 @@ if test x$INTL = xyes; then
fi;
AC_ARG_WITH(localedir,
- [ --with-localedir=DIR Translation files in DIR [[PREFIX/share/locale]] ],
- [ LOCALEDIR="$withval" ],
- [ LOCALEDIR='${prefix}/share/locale' ])
+ AC_HELP_STRING([--with-localedir=DIR],
+ [translation files in DIR
+ [[PREFIX/share/locale]]]),
+ LOCALEDIR=$withval, LOCALEDIR='${prefix}/share/locale')
fi
################################################################################
AC_ARG_WITH(confdir,
- [ --with-confdir=DIR Configuration files in DIR [[/etc]]],
- [ CONFDIR="$withval" ],
- [ CONFDIR='/etc' ])
+ AC_HELP_STRING([--with-confdir=DIR],
+ [configuration files in DIR [[/etc]]]),
+ CONFDIR=$withval, CONFDIR="/etc")
AC_ARG_WITH(staticdir,
- [ --with-staticdir=DIR Static binary in DIR [[EPREFIX/sbin]]],
- [ STATICDIR="$withval" ],
- [ STATICDIR='${exec_prefix}/sbin' ])
+ AC_HELP_STRING([--with-staticdir=DIR],
+ [static binaries in DIR [[EPREFIX/sbin]]]),
+ STATICDIR=$withval, STATICDIR='${exec_prefix}/sbin')
AC_ARG_WITH(usrlibdir,
- [ --with-usrlibdir=DIR],
- [ usrlibdir="$withval"],
- [ usrlibdir='${prefix}/lib' ])
+ AC_HELP_STRING([--with-usrlibdir=DIR],
+ [usrlib in DIR [[PREFIX/lib]]]),
+ usrlibdir=$withval, usrlibdir='${prefix}/lib')
AC_ARG_WITH(usrsbindir,
- [ --with-usrsbindir=DIR],
- [ usrsbindir="$withval"],
- [ usrsbindir='${prefix}/sbin' ])
+ AC_HELP_STRING([--with-usrsbindir=DIR],
+ [usrsbin executables in DIR [[PREFIX/sbin]]]),
+ usrsbindir=$withval, usrsbindir='${prefix}/sbin')
################################################################################
AC_ARG_WITH(udev_prefix,
- [ --with-udev-prefix=UPREFIX Install udev rule files in UPREFIX [[EPREFIX]]],
- [ udev_prefix="$withval"],
- [ udev_prefix='${exec_prefix}' ])
+ AC_HELP_STRING([--with-udev-prefix=UPREFIX],
+ [install udev rule files in UPREFIX [[EPREFIX]]]),
+ udev_prefix=$withval, udev_prefix='${exec_prefix}')
AC_ARG_WITH(udevdir,
- [ --with-udevdir=DIR udev rules in DIR [[UPREFIX/lib/udev/rules.d]]],
- [ udevdir="$withval"],
- [ udevdir='${udev_prefix}/lib/udev/rules.d' ])
+ AC_HELP_STRING([--with-udevdir=DIR],
+ [udev rules in DIR [[UPREFIX/lib/udev/rules.d]]]),
+ udevdir=$withval, udevdir='${udev_prefix}/lib/udev/rules.d')
################################################################################
dnl -- Ensure additional headers required
@@ -1037,71 +1073,76 @@ AC_DEFINE_UNQUOTED(LVM_PATH, ["$lvm_exec_prefix/sbin/lvm"], [Path to lvm binary.
if test "$CLVMD" != none; then
clvmd_prefix=$ac_default_prefix
test "$prefix" != NONE && clvmd_prefix=$prefix
- AC_DEFINE_UNQUOTED(CLVMD_PATH, ["$clvmd_prefix/sbin/clvmd"], [Path to clvmd binary.])
+ AC_DEFINE_UNQUOTED(CLVMD_PATH, ["$clvmd_prefix/sbin/clvmd"],
+ [Path to clvmd binary.])
fi
################################################################################
dnl -- dmeventd pidfile and executable path
-AH_TEMPLATE(DMEVENTD_PIDFILE, [Path to dmeventd pidfile.])
if test "$BUILD_DMEVENTD" = yes; then
AC_ARG_WITH(dmeventd-pidfile,
- [ --with-dmeventd-pidfile=PATH dmeventd pidfile [[/var/run/dmeventd.pid]] ],
- [ AC_DEFINE_UNQUOTED(DMEVENTD_PIDFILE,"$withval") ],
- [ AC_DEFINE_UNQUOTED(DMEVENTD_PIDFILE,"/var/run/dmeventd.pid") ])
+ AC_HELP_STRING([--with-dmeventd-pidfile=PATH],
+ [dmeventd pidfile [[/var/run/dmeventd.pid]]]),
+ DMEVENTD_PIDFILE=$withval,
+ DMEVENTD_PIDFILE="/var/run/dmeventd.pid")
+ AC_DEFINE_UNQUOTED(DMEVENTD_PIDFILE, ["$DMEVENTD_PIDFILE"],
+ [Path to dmeventd pidfile.])
fi
-AH_TEMPLATE(DMEVENTD_PATH, [Path to dmeventd binary.])
if test "$BUILD_DMEVENTD" = yes; then
AC_ARG_WITH(dmeventd-path,
- [ --with-dmeventd-path=PATH dmeventd path [[EPREFIX/sbin/dmeventd]] ],
- [ AC_DEFINE_UNQUOTED(DMEVENTD_PATH,"$withval") ],
- [ AC_DEFINE_UNQUOTED(DMEVENTD_PATH,"$lvm_exec_prefix/sbin/dmeventd") ])
+ AC_HELP_STRING([--with-dmeventd-path=PATH],
+ [dmeventd path [[EPREFIX/sbin/dmeventd]]]),
+ DMEVENTD_PATH=$withval,
+ DMEVENTD_PATH="$lvm_exec_prefix/sbin/dmeventd")
+ AC_DEFINE_UNQUOTED(DMEVENTD_PATH, ["$DMEVENTD_PATH"],
+ [Path to dmeventd binary.])
fi
################################################################################
dnl -- various defaults
-AH_TEMPLATE(DEFAULT_SYS_DIR, [Path to LVM system directory.])
AC_ARG_WITH(default-system-dir,
- [ --with-default-system-dir=DIR Default LVM system directory [[/etc/lvm]] ],
- [ DEFAULT_SYS_DIR="$withval" ],
- [ DEFAULT_SYS_DIR="/etc/lvm" ])
-AC_DEFINE_UNQUOTED(DEFAULT_SYS_DIR,["$DEFAULT_SYS_DIR"] )
+ AC_HELP_STRING([--with-default-system-dir=DIR],
+ [default LVM system directory [[/etc/lvm]]]),
+ DEFAULT_SYS_DIR=$withval, DEFAULT_SYS_DIR="/etc/lvm")
+AC_DEFINE_UNQUOTED(DEFAULT_SYS_DIR, ["$DEFAULT_SYS_DIR"],
+ [Path to LVM system directory.])
-AH_TEMPLATE(DEFAULT_ARCHIVE_SUBDIR, [Name of default metadata archive subdirectory.])
AC_ARG_WITH(default-archive-subdir,
- [ --with-default-archive-subdir=SUBDIR Default metadata archive subdir [[archive]] ],
- [ DEFAULT_ARCHIVE_SUBDIR="$withval" ],
- [ DEFAULT_ARCHIVE_SUBDIR="archive" ])
-AC_DEFINE_UNQUOTED(DEFAULT_ARCHIVE_SUBDIR,["$DEFAULT_ARCHIVE_SUBDIR"])
+ AC_HELP_STRING([--with-default-archive-subdir=SUBDIR],
+ [default metadata archive subdir [[archive]]]),
+ DEFAULT_ARCHIVE_SUBDIR=$withval, DEFAULT_ARCHIVE_SUBDIR=archive)
+AC_DEFINE_UNQUOTED(DEFAULT_ARCHIVE_SUBDIR, ["$DEFAULT_ARCHIVE_SUBDIR"],
+ [Name of default metadata archive subdirectory.])
-AH_TEMPLATE(DEFAULT_BACKUP_SUBDIR, [Name of default metadata backup subdirectory.])
AC_ARG_WITH(default-backup-subdir,
- [ --with-default-backup-subdir=SUBDIR Default metadata backup subdir [[backup]] ],
- [ DEFAULT_BACKUP_SUBDIR="$withval" ],
- [ DEFAULT_BACKUP_SUBDIR="backup" ])
-AC_DEFINE_UNQUOTED(DEFAULT_BACKUP_SUBDIR,["$DEFAULT_BACKUP_SUBDIR"] )
+ AC_HELP_STRING([--with-default-backup-subdir=SUBDIR],
+ [default metadata backup subdir [[backup]]]),
+ DEFAULT_BACKUP_SUBDIR=$withval, DEFAULT_BACKUP_SUBDIR=backup)
+AC_DEFINE_UNQUOTED(DEFAULT_BACKUP_SUBDIR, ["$DEFAULT_BACKUP_SUBDIR"],
+ [Name of default metadata backup subdirectory.])
-AH_TEMPLATE(DEFAULT_CACHE_SUBDIR, [Name of default metadata cache subdirectory.])
AC_ARG_WITH(default-cache-subdir,
- [ --with-default-cache-subdir=SUBDIR Default metadata cache subdir [[cache]] ],
- [ DEFAULT_CACHE_SUBDIR="$withval" ],
- [ DEFAULT_CACHE_SUBDIR="cache" ])
-AC_DEFINE_UNQUOTED(DEFAULT_CACHE_SUBDIR,["$DEFAULT_CACHE_SUBDIR"] )
+ AC_HELP_STRING([--with-default-cache-subdir=SUBDIR],
+ [default metadata cache subdir [[cache]]]),
+ DEFAULT_CACHE_SUBDIR=$withval, DEFAULT_CACHE_SUBDIR=cache)
+AC_DEFINE_UNQUOTED(DEFAULT_CACHE_SUBDIR, ["$DEFAULT_CACHE_SUBDIR"],
+ [Name of default metadata cache subdirectory.])
-AH_TEMPLATE(DEFAULT_LOCK_DIR, [Name of default locking directory.])
AC_ARG_WITH(default-locking-dir,
- [ --with-default-locking-dir=DIR Default locking directory [[/var/lock/lvm]] ],
- [ DEFAULT_LOCK_DIR="$withval" ],
- [ DEFAULT_LOCK_DIR="/var/lock/lvm" ])
-AC_DEFINE_UNQUOTED(DEFAULT_LOCK_DIR,["$DEFAULT_LOCK_DIR"] )
+ AC_HELP_STRING([--with-default-locking-dir=DIR],
+ [default locking directory [[/var/lock/lvm]]]),
+ DEFAULT_LOCK_DIR=$withval, DEFAULT_LOCK_DIR="/var/lock/lvm")
+AC_DEFINE_UNQUOTED(DEFAULT_LOCK_DIR, ["$DEFAULT_LOCK_DIR"],
+ [Name of default locking directory.])
################################################################################
dnl -- which kernel interface to use (ioctl only)
AC_MSG_CHECKING(for kernel interface choice)
AC_ARG_WITH(interface,
- [ --with-interface=IFACE Choose kernel interface (ioctl) [[ioctl]] ],
- [ interface="$withval" ],
- [ interface=ioctl ])
+ AC_HELP_STRING([--with-interface=IFACE],
+ [choose kernel interface (ioctl) [[ioctl]]]),
+ interface=$withval, interface=ioctl)
if [[ "x$interface" != xioctl ]];
then
AC_MSG_ERROR(--with-interface=ioctl required. fs no longer supported.)