summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJoe Thornber <thornber@redhat.com>2010-08-09 10:56:01 +0000
committerJoe Thornber <thornber@redhat.com>2010-08-09 10:56:01 +0000
commit52e1564fddf769d481ef8bc89a01c680777bcbbc (patch)
tree9ebf3a6c825029c278ec2300ab2bec33f9b7fc36 /configure.in
parentfae2c492595add56718d45efaee36438e4279600 (diff)
downloadlvm2-52e1564fddf769d481ef8bc89a01c680777bcbbc.tar.gz
lvm2-52e1564fddf769d481ef8bc89a01c680777bcbbc.tar.xz
lvm2-52e1564fddf769d481ef8bc89a01c680777bcbbc.zip
[MM] Make valgrind aware of the pool allocators
./configure with --enable-valgrind-pool to enable this.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d3df6973..70c6fa1f 100644
--- a/configure.in
+++ b/configure.in
@@ -717,6 +717,19 @@ if test "$TESTING" = yes; then
fi
################################################################################
+dnl -- Enable valgrind awareness of memory pools
+AC_MSG_CHECKING(whether to enable valgrind awareness of pools)
+AC_ARG_ENABLE(valgrind_pool,
+ AC_HELP_STRING(--enable-valgrind-pool, [enable valgrind awareness of pools]),
+ VALGRIND_POOL=$enableval, VALGRIND_POOL=no)
+AC_MSG_RESULT($VALGRIND_POOL)
+
+if test "$VALGRIND_POOL" = yes; then
+ AC_CHECK_HEADERS([valgrind/memcheck.h], , [AC_MSG_ERROR(bailing out)])
+ AC_DEFINE([VALGRIND_POOL], 1, [Enable a valgrind aware build of pool])
+fi
+
+################################################################################
dnl -- Disable devmapper
AC_MSG_CHECKING(whether to use device-mapper)
AC_ARG_ENABLE(devmapper,
@@ -1343,6 +1356,7 @@ tools/Makefile
udev/Makefile
unit-tests/datastruct/Makefile
unit-tests/regex/Makefile
+unit-tests/mm/Makefile
])
AC_OUTPUT