summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJonathan Earl Brassow <jbrassow@redhat.com>2009-08-13 16:34:07 +0000
committerJonathan Earl Brassow <jbrassow@redhat.com>2009-08-13 16:34:07 +0000
commit3c14bcca3314365e97a21d9313e8700f32a4ed7b (patch)
treecd66f61c8cc446f6e6004a6562a4e3337cab7368 /configure.in
parent8f26e18c13283dfcb02c9ee350999deacfda4869 (diff)
downloadlvm2-3c14bcca3314365e97a21d9313e8700f32a4ed7b.tar.gz
lvm2-3c14bcca3314365e97a21d9313e8700f32a4ed7b.tar.xz
lvm2-3c14bcca3314365e97a21d9313e8700f32a4ed7b.zip
cluster log daemon (clogd): Add to LVM build system
This check-in includes the touch-ups, make file changes, copyrights, and other necessities to include the cluster log daemon into the build system. [autoconf still needs to be run to generate the 'configure' and 'Makefile' files.]
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 21 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 2855c2eb..5e89c8d7 100644
--- a/configure.in
+++ b/configure.in
@@ -63,7 +63,7 @@ esac
################################################################################
dnl -- Checks for programs.
-AC_PROG_SED
+m4_pattern_allow(AC_PROG_SED)
AC_PROG_AWK
AC_PROG_CC
@@ -72,7 +72,7 @@ AC_PROG_GCC_TRADITIONAL
AC_PROG_INSTALL
AC_PROG_LN_S
AC_PROG_MAKE_SET
-AC_PROG_MKDIR_P
+m4_pattern_allow(AC_PROG_MKDIR_P)
AC_PROG_RANLIB
AC_PATH_PROG(CFLOW_CMD, cflow)
AC_PATH_PROG(CSCOPE_CMD, cscope)
@@ -353,6 +353,23 @@ if [[ "x$CLVMD" = xall -o `expr x"$CLVMD" : '.*corosync.*'` != 0 ]]; then
fi
################################################################################
+dnl -- Build cluster log daemon
+AC_MSG_CHECKING(whether to build cluster log daemon)
+AC_ARG_ENABLE(clogd, [ --enable-clogd Enable the cluster log daemon],
+CLOGD=$enableval)
+AC_MSG_RESULT($CLOGD)
+
+dnl -- Look for corosync libraries if required.
+if [[ "x$CLOGD" = xall -o `expr x"$CLOGD" : '.*corosync.*'` != 0 ]]; then
+#
+# FIXME: ALSO NEED TO CHECK FOR CHECKPOINT MODULE
+#
+ PKG_CHECK_MODULES(CPG, libcpg, [],
+ [AC_MSG_RESULT([no pkg for libcpg library, using -lcpg]);
+ CPG_LIBS="-lcpg"])
+fi
+
+################################################################################
dnl -- Enable debugging
AC_MSG_CHECKING(whether to enable debugging)
AC_ARG_ENABLE(debug, [ --enable-debug Enable debugging],
@@ -801,6 +818,7 @@ AC_SUBST(CLDNOWHOLEARCHIVE)
AC_SUBST(CLDWHOLEARCHIVE)
AC_SUBST(CLUSTER)
AC_SUBST(CLVMD)
+AC_SUBST(CLOGD)
AC_SUBST(CMDLIB)
AC_SUBST(CONFDB_CFLAGS)
AC_SUBST(CONFDB_LIBS)
@@ -870,6 +888,7 @@ Makefile
make.tmpl
daemons/Makefile
daemons/clvmd/Makefile
+daemons/clogd/Makefile
daemons/dmeventd/Makefile
daemons/dmeventd/libdevmapper-event.pc
daemons/dmeventd/plugins/Makefile