summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJoe Thornber <thornber@redhat.com>2010-07-20 14:38:44 +0000
committerJoe Thornber <thornber@redhat.com>2010-07-20 14:38:44 +0000
commit1033d120404c0e41ced5f36361e412ac03a3461f (patch)
tree8776b2d0770ad642176c9e079987e621251f1e23 /configure.in
parent60f425d1b3508d71883ac1a4501f6ab7f3e32b08 (diff)
downloadlvm2-1033d120404c0e41ced5f36361e412ac03a3461f.tar.gz
lvm2-1033d120404c0e41ced5f36361e412ac03a3461f.tar.xz
lvm2-1033d120404c0e41ced5f36361e412ac03a3461f.zip
Report generators for unit tests and memory checks. Configure with
--enable-testing.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 6b5d65a3..db1376f9 100644
--- a/configure.in
+++ b/configure.in
@@ -701,6 +701,22 @@ if test "x$PROFILING" = xyes; then
fi
################################################################################
+dnl -- Enable testing
+AC_MSG_CHECKING(whether to enable unit testing)
+AC_ARG_ENABLE(testing,
+ AC_HELP_STRING(--enable-testing, [enable testing targets in the makefile]),
+ TESTING=$enableval, TESTING=no)
+AC_MSG_RESULT($TESTING)
+
+if test "$TESTING" = yes; then
+ AC_PATH_PROG(RUBY19, ruby1.9)
+ AC_PATH_PROG(VALGRIND, valgrind)
+ if test -z "$RUBY19" -o -z "$VALGRIND"; then
+ AC_MSG_ERROR([ruby1.9 and valgrind are required for testing])
+ fi
+fi
+
+################################################################################
dnl -- Disable devmapper
AC_MSG_CHECKING(whether to use device-mapper)
AC_ARG_ENABLE(devmapper,
@@ -1260,6 +1276,7 @@ AC_SUBST(SELINUX_PC)
AC_SUBST(SNAPSHOTS)
AC_SUBST(STATICDIR)
AC_SUBST(STATIC_LINK)
+AC_SUBST(TESTING)
AC_SUBST(UDEV_LIBS)
AC_SUBST(UDEV_PC)
AC_SUBST(UDEV_RULES)