summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/configure.in b/src/configure.in
index c2eaf78d83..7dded28f22 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -6,6 +6,15 @@ if test x"$runstatedir" == x; then
fi
AC_SUBST(runstatedir)
+# Don't make duplicate profile path entries for /etc/krb5.conf if
+# $sysconfdir is /etc
+if test "$sysconfdir" == /etc; then
+ SYSCONFCONF=""
+else
+ SYSCONFCONF=":${sysconfdir}/krb5.conf"
+fi
+AC_SUBST(SYSCONFCONF)
+
CONFIG_RULES
KRB5_VERSION=K5_VERSION
AC_SUBST(KRB5_VERSION)