summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorGreg Hudson <ghudson@mit.edu>2011-11-29 22:49:56 +0000
committerGreg Hudson <ghudson@mit.edu>2011-11-29 22:49:56 +0000
commite6e2928c0dc113d99f1c5dd8b35fee146c577ec3 (patch)
treeed7796e0b20ae5716f59475af45e8dbb4a00cd2e /src/configure.in
parentdfa35ab001beb56299cac9c2386f05cd1a85a033 (diff)
downloadkrb5-e6e2928c0dc113d99f1c5dd8b35fee146c577ec3.tar.gz
krb5-e6e2928c0dc113d99f1c5dd8b35fee146c577ec3.tar.xz
krb5-e6e2928c0dc113d99f1c5dd8b35fee146c577ec3.zip
Fix --with-system-verto without pkg-config
If we're using the system verto and pkg-config isn't found but libverto is, set VERTO_LIBS to just -lverto as there won't be a k5ev module. ticket: 7029 target_version: 1.10 tags: pullup git-svn-id: svn://anonsvn.mit.edu/krb5/trunk@25493 dc483132-0cff-0310-8789-dd5450dbe970
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/configure.in b/src/configure.in
index 953d5767d1..3101439fdb 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -1224,7 +1224,7 @@ if test "x$with_system_verto" != xno; then
VERTO_LIBS=`pkg-config --libs libverto`
VERTO_VERSION=sys
else
- AC_CHECK_LIB([verto], [verto_run], [VERTO_VERSION=sys],
+ AC_CHECK_LIB([verto], [verto_run], [VERTO_VERSION=sys; VERTO_LIBS=-lverto],
[if test "x$with_system_verto" = xyes; then
AC_MSG_ERROR([cannot detect system libverto])
fi])