summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorGreg Hudson <ghudson@mit.edu>2011-09-06 23:23:39 +0000
committerGreg Hudson <ghudson@mit.edu>2011-09-06 23:23:39 +0000
commitd6e6d23d5fdc21a1ce613c3fc7f378de7b05d47c (patch)
tree4642dbe56bf913d0c4b730cb2b4562ccc1ed0174 /src/configure.in
parente68eef8d34b9527c3a24c9f0d6c0ae9b0be0e76f (diff)
downloadkrb5-d6e6d23d5fdc21a1ce613c3fc7f378de7b05d47c.tar.gz
krb5-d6e6d23d5fdc21a1ce613c3fc7f378de7b05d47c.tar.xz
krb5-d6e6d23d5fdc21a1ce613c3fc7f378de7b05d47c.zip
Change how bundled libverto is linked
Give libverto-k5ev a header file. When using the internal verto library, link against -lverto-k5ev and use verto_default_k5ev() instead of verto_default(), bypassing the module loading logic and making static builds possible. git-svn-id: svn://anonsvn.mit.edu/krb5/trunk@25166 dc483132-0cff-0310-8789-dd5450dbe970
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/configure.in b/src/configure.in
index 38889cf529..51262d8c98 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -1162,7 +1162,7 @@ AC_ARG_WITH([system-verto],
[AC_HELP_STRING([--with-system-verto], [always use system verto library])],
[], [with_system_verto=default])
VERTO_CFLAGS=
-VERTO_LIBS=-lverto
+VERTO_LIBS="-lverto-k5ev -lverto"
VERTO_VERSION=k5
if test "x$with_system_verto" != xno; then
if verto_cflags=`pkg-config --cflags libverto 2>&1`; then
@@ -1180,6 +1180,7 @@ if test "x$VERTO_VERSION" = xsys; then
AC_MSG_NOTICE([Using system libverto])
else
AC_MSG_RESULT([Using built-in libverto])
+ AC_DEFINE([INTERNAL_VERTO],[1],[Define if using bundled libverto])
fi
AC_SUBST([VERTO_CFLAGS])
AC_SUBST([VERTO_LIBS])