summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorGreg Hudson <ghudson@mit.edu>2011-02-24 09:59:22 +0000
committerGreg Hudson <ghudson@mit.edu>2011-02-24 09:59:22 +0000
commitad780e3f3d89bee45d48da3e342df0fb8185cdbf (patch)
tree71839cad23ce0c89c57190c68db8ce4d0f845b68 /src/configure.in
parent76a54ee9451a793b2ebd313865fbc10619081d26 (diff)
downloadkrb5-ad780e3f3d89bee45d48da3e342df0fb8185cdbf.tar.gz
krb5-ad780e3f3d89bee45d48da3e342df0fb8185cdbf.tar.xz
krb5-ad780e3f3d89bee45d48da3e342df0fb8185cdbf.zip
Make Fortuna the default PRNG algorithm
ticket: 6874 git-svn-id: svn://anonsvn.mit.edu/krb5/trunk@24653 dc483132-0cff-0310-8789-dd5450dbe970
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in16
1 files changed, 3 insertions, 13 deletions
diff --git a/src/configure.in b/src/configure.in
index 3ec2b06b39..1220f96c69 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -154,28 +154,18 @@ AC_SUBST(CRYPTO_IMPL_LIBS)
if test "$CRYPTO_IMPL" = nss; then
PRNG_ALG="nss"
else
-PRNG_ALG="yarrow"
AC_ARG_WITH([prng-alg],
-AC_HELP_STRING([--with-prng-alg=ALG], [use specified PRNG algorithm. Ignored for nss. @<:@yarrow@:>@]),
+AC_HELP_STRING([--with-prng-alg=ALG], [use specified PRNG algorithm. Ignored for nss. @<:@fortuna@:>@]),
[PRNG_ALG=$withval
AC_MSG_RESULT("k5crypto will use \'$withval\'")
-], withval=yarrow)
+], PRNG_ALG=fortuna)
fi
AC_CONFIG_COMMANDS(PRNG_ALG, , PRNG_ALG=$PRNG_ALG)
AC_SUBST(PRNG_ALG)
-if test "$withval" = fortuna; then
+if test "$PRNG_ALG" = fortuna; then
AC_DEFINE(FORTUNA,1,[Define if Fortuna PRNG is selected])
fi
-AC_ARG_ENABLE([fortuna-test],
- [ --enable-fortuna-test build to test Fortuna PRNG],,enableval=no)
-if test "$enableval" = yes ; then
- PRNG_FORTUNA_TEST="yes"
- AC_DEFINE(TEST_FORTUNA,1,[Create a special build to test Fortuna PRNG])
- AC_CONFIG_COMMANDS(PRNG_FORTUNA_TEST, , PRNG_FORTUNA_TEST=$PRNG_FORTUNA_TEST)
- AC_SUBST(PRNG_FORTUNA_TEST)
-fi
-
# --with-kdc-kdb-update makes the KDC update the database with last request
# information and failure information.