summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorGreg Hudson <ghudson@mit.edu>2011-05-02 20:45:38 +0000
committerGreg Hudson <ghudson@mit.edu>2011-05-02 20:45:38 +0000
commitabf4901899c198721df83b047e5d3df6f7dcb108 (patch)
tree3f6b2021d773816fe26221772511df4e2978e921 /src/configure.in
parent78e9341c1f347e64944dc9e52b4278dedea2f414 (diff)
downloadkrb5-abf4901899c198721df83b047e5d3df6f7dcb108.tar.gz
krb5-abf4901899c198721df83b047e5d3df6f7dcb108.tar.xz
krb5-abf4901899c198721df83b047e5d3df6f7dcb108.zip
Add poll support to sendto_kdc.c so that it can work in processes with
large numbers of open files. Move krb5int_cm_call_select() to a separate file so that the poll support doesn't interfere with net-server.c's continuing use of select. ticket: 6905 git-svn-id: svn://anonsvn.mit.edu/krb5/trunk@24908 dc483132-0cff-0310-8789-dd5450dbe970
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/configure.in b/src/configure.in
index b85bc911a2..bb623e5567 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -67,7 +67,7 @@ LIBUTIL=-lutil
])
AC_SUBST(LIBUTIL)
# for kdc
-AC_CHECK_HEADERS(syslog.h sys/select.h sys/sockio.h ifaddrs.h unistd.h)
+AC_CHECK_HEADERS(syslog.h sys/sockio.h ifaddrs.h unistd.h)
AC_CHECK_FUNCS(openlog syslog closelog strftime vsprintf vasprintf vsnprintf)
AC_CHECK_FUNCS(strlcpy)
EXTRA_SUPPORT_SYMS=
@@ -472,7 +472,7 @@ AC_CHECK_HEADER(termios.h,
AC_DEFINE(POSIX_TERMIOS,1,[Define if termios.h exists and tcsetattr exists]))])
KRB5_SIGTYPE
-AC_CHECK_HEADERS(stdlib.h string.h stddef.h sys/types.h sys/file.h sys/param.h sys/stat.h sys/time.h netinet/in.h sys/uio.h sys/filio.h sys/select.h time.h paths.h errno.h)
+AC_CHECK_HEADERS(poll.h stdlib.h string.h stddef.h sys/types.h sys/file.h sys/param.h sys/stat.h sys/time.h netinet/in.h sys/uio.h sys/filio.h sys/select.h time.h paths.h errno.h)
# If compiling with IPv6 support, test if in6addr_any functions.
# Irix 6.5.16 defines it, but lacks support in the C library.