summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorGreg Hudson <ghudson@mit.edu>2011-09-02 17:07:45 +0000
committerGreg Hudson <ghudson@mit.edu>2011-09-02 17:07:45 +0000
commit6ef4ba5b6ac16653034583cabfeb6297b30025a7 (patch)
tree19cd275f4852c38798031c7beca42c869ee3c156 /src/configure.in
parenta10ffe0492a13ae01530459981ee0bb885a8f0c7 (diff)
downloadkrb5-6ef4ba5b6ac16653034583cabfeb6297b30025a7.tar.gz
krb5-6ef4ba5b6ac16653034583cabfeb6297b30025a7.tar.xz
krb5-6ef4ba5b6ac16653034583cabfeb6297b30025a7.zip
Create k5ev verto module from libev sources
Add configure and build support for libverto and the libverto-k5ev module. Fix the version script rules to work for libraries with hyphens in their names. git-svn-id: svn://anonsvn.mit.edu/krb5/trunk@25127 dc483132-0cff-0310-8789-dd5450dbe970
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/configure.in b/src/configure.in
index 4e61e8f591..5d3f5264d1 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -1142,10 +1142,38 @@ fi
AC_SUBST([RL_CFLAGS])
AC_SUBST([RL_LIBS])
+AC_ARG_WITH([system-verto],
+ [AC_HELP_STRING([--with-system-verto], [always use system verto library])],
+ [], [with_system_verto=default])
+VERTO_CFLAGS=
+VERTO_LIBS=-lverto
+VERTO_VERSION=k5
+if test "x$with_system_verto" != xno; then
+ if verto_cflags=`pkg-config --cflags libverto 2>&1`; then
+ VERTO_CFLAGS=$verto_cflags
+ VERTO_LIBS=`pkg-config --libs libverto`
+ VERTO_VERSION=sys
+ else
+ AC_CHECK_LIB([verto], [verto_run], [VERTO_VERSION=sys],
+ [if test "x$with_system_verto" = xyes; then
+ AC_MSG_ERROR([cannot detect system libverto])
+ fi])
+ fi
+fi
+if test "x$VERTO_VERSION" = xsys; then
+ AC_MSG_NOTICE([Using system libverto])
+else
+ AC_MSG_RESULT([Using built-in libverto])
+fi
+AC_SUBST([VERTO_CFLAGS])
+AC_SUBST([VERTO_LIBS])
+AC_SUBST([VERTO_VERSION])
+
AC_CONFIG_FILES(krb5-config, [chmod +x krb5-config])
V5_AC_OUTPUT_MAKEFILE(.
util util/support util/profile util/profile/testmod util/send-pr
+ util/verto util/k5ev
lib lib/kdb