summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorGreg Hudson <ghudson@mit.edu>2011-07-22 16:37:00 +0000
committerGreg Hudson <ghudson@mit.edu>2011-07-22 16:37:00 +0000
commit648e4b9fa3f36f10e517b4e6b80329980603d17c (patch)
tree168b400e47d2f30a005b11ea34e11a01dba7d285 /src/configure.in
parented8bc7b5e8ba1f72a0ae083b3005fbe18718544b (diff)
downloadkrb5-648e4b9fa3f36f10e517b4e6b80329980603d17c.tar.gz
krb5-648e4b9fa3f36f10e517b4e6b80329980603d17c.tar.xz
krb5-648e4b9fa3f36f10e517b4e6b80329980603d17c.zip
Fix configure logic when libedit isn't present
The configure script was correctly detecting that libedit was absent, but was setting RL_CFLAGS to garbage in the process. git-svn-id: svn://anonsvn.mit.edu/krb5/trunk@25036 dc483132-0cff-0310-8789-dd5450dbe970
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/configure.in b/src/configure.in
index b057a3b483..a5fa4eeea2 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -1116,7 +1116,8 @@ fi
RL_CFLAGS=
RL_LIBS=
if test "x$with_libedit" != xno; then
- if RL_CFLAGS=`pkg-config --cflags libedit 2>&1`; then
+ if rl_cflags=`pkg-config --cflags libedit 2>&1`; then
+ RL_CFLAGS=$rl_cflags
RL_LIBS=`pkg-config --libs libedit`
AC_DEFINE([HAVE_LIBEDIT], 1, [Define if building with libedit.])
AC_MSG_RESULT([using libedit])