summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorTom Yu <tlyu@mit.edu>2011-07-11 17:53:25 +0000
committerTom Yu <tlyu@mit.edu>2011-07-11 17:53:25 +0000
commit478addb5c6b8b0cdb2454614d5226a23e7b0b356 (patch)
tree0def747888225f3eba4d3daac84604a54706989e /src/configure.in
parent99fbb4c5d5956428db3ae1307ffc29911e45aff5 (diff)
downloadkrb5-478addb5c6b8b0cdb2454614d5226a23e7b0b356.tar.gz
krb5-478addb5c6b8b0cdb2454614d5226a23e7b0b356.tar.xz
krb5-478addb5c6b8b0cdb2454614d5226a23e7b0b356.zip
use timegm() for krb5int_gmt_mktime() when available
Use timegm() if it is available, so that krb5int_gmt_mktime() functions correctly on systems configured with a "right" (leap-second-aware) time zone. It is arguably an OS bug if a "right" time zone can be configured on a system that lacks timegm(). Due to a current lack of evidence of affected systems, the additional workaround of replacing gmtime() with a version that always ignores leap seconds is deferred. ticket: 6928 git-svn-id: svn://anonsvn.mit.edu/krb5/trunk@25018 dc483132-0cff-0310-8789-dd5450dbe970
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/configure.in b/src/configure.in
index 641a0f364d..8789de75b7 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -201,7 +201,7 @@ AC_CONFIG_HEADERS(include/autoconf.h, [echo timestamp > include/autoconf.stamp])
AC_PROG_LEX
AC_C_CONST
AC_HEADER_DIRENT
-AC_CHECK_FUNCS(strdup setvbuf inet_ntoa inet_aton seteuid setresuid setreuid setegid setresgid setregid setsid flock fchmod chmod strftime strptime geteuid setenv unsetenv getenv gmtime_r localtime_r bswap16 bswap64 mkstemp getusershell access getcwd srand48 srand srandom stat strchr strerror strerror_r)
+AC_CHECK_FUNCS(strdup setvbuf inet_ntoa inet_aton seteuid setresuid setreuid setegid setresgid setregid setsid flock fchmod chmod strftime strptime geteuid setenv unsetenv getenv gmtime_r localtime_r bswap16 bswap64 mkstemp getusershell access getcwd srand48 srand srandom stat strchr strerror strerror_r timegm)
AC_CHECK_FUNC(mkstemp,
[MKSTEMP_ST_OBJ=