summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorGreg Hudson <ghudson@mit.edu>2011-11-01 03:49:16 +0000
committerGreg Hudson <ghudson@mit.edu>2011-11-01 03:49:16 +0000
commit3001a823a73d8cfd2599a8ad66b9c6038d1c28bc (patch)
tree2a5cc59e1e14eaa4458c720dbe1f4d4db124221b /src/configure.in
parent286b215bd829075f04576b65d55993fdc8e11b47 (diff)
downloadkrb5-3001a823a73d8cfd2599a8ad66b9c6038d1c28bc.tar.gz
krb5-3001a823a73d8cfd2599a8ad66b9c6038d1c28bc.tar.xz
krb5-3001a823a73d8cfd2599a8ad66b9c6038d1c28bc.zip
Conditionalize po subdir on msgfmt, not dgetext
The presence of dgettext in libc or libintl doesn't imply that msgfmt is installed, so conditionalize building the po subdir on whether msgfmt is installed. ticket: 6997 target_version: 1.10 tags: pullup git-svn-id: svn://anonsvn.mit.edu/krb5/trunk@25425 dc483132-0cff-0310-8789-dd5450dbe970
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/configure.in b/src/configure.in
index 9de430f267..e5de90335d 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -66,12 +66,16 @@ LIBUTIL=-lutil
])
AC_SUBST(LIBUTIL)
-po=
AC_CHECK_HEADER(libintl.h, [
AC_SEARCH_LIBS(dgettext, intl, [
- po=po
AC_DEFINE(ENABLE_NLS, 1,
[Define if translation functions should be used.])])])
+
+AC_CHECK_PROG(MSGFMT,msgfmt,msgfmt)
+po=
+if test x"$MSGFMT" != x; then
+ po=po
+fi
AC_SUBST(po)
# for kdc