summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorGreg Hudson <ghudson@mit.edu>2012-11-15 14:26:23 -0500
committerGreg Hudson <ghudson@mit.edu>2012-11-15 14:26:23 -0500
commit2e002b96f5ce0a78d65b7f0c9e70c352788dea78 (patch)
treeb43fb2901d59f2b01643e5e47f2d80d669852467 /src/configure.in
parent4f349b6e154eb05e591cd0de10791e29f4c44fb9 (diff)
downloadkrb5-2e002b96f5ce0a78d65b7f0c9e70c352788dea78.tar.gz
krb5-2e002b96f5ce0a78d65b7f0c9e70c352788dea78.tar.xz
krb5-2e002b96f5ce0a78d65b7f0c9e70c352788dea78.zip
Avoid using grep -q in configure.in
grep -q isn't as portable as we would like, so don't use it.
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/configure.in b/src/configure.in
index 5a1539c096..faf93a1c94 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -1265,7 +1265,7 @@ if test "x$with_krb5_config" != xno; then
if test "x$with_krb5_config" = xyes; then
with_krb5_config=krb5-config
fi
- if $with_krb5_config --help 2>&1 | grep -q defccname; then
+ if $with_krb5_config --help 2>&1 | grep defccname >/dev/null; then
AC_MSG_NOTICE([Using $with_krb5_config for build defaults])
: "${DEFCCNAME=`$with_krb5_config --defccname`}"
: "${DEFKTNAME=`$with_krb5_config --defktname`}"