summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorGreg Hudson <ghudson@mit.edu>2014-02-01 15:20:08 -0500
committerGreg Hudson <ghudson@mit.edu>2014-02-26 16:15:19 -0500
commit17e205070745e4712d40eed32d92d02edb47009f (patch)
tree7b84dc2f536d8c73da8155a186fbbc23c3b88dc1 /src/configure.in
parent4c376a3776aed0fb19b761406eaa2e0516ff6735 (diff)
downloadkrb5-17e205070745e4712d40eed32d92d02edb47009f.tar.gz
krb5-17e205070745e4712d40eed32d92d02edb47009f.tar.xz
krb5-17e205070745e4712d40eed32d92d02edb47009f.zip
Assume <stdint.h> and fixed-width types
Make unconditional use of <stdint.h> and fixed-width types such as uint32_t. k5-plugin.h doesn't use any special integer types, so remove the conditional include block there. Nothing uses INT64_FMT/UINT64_FMT, so leave those out of k5-platform.h for now.
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in57
1 files changed, 0 insertions, 57 deletions
diff --git a/src/configure.in b/src/configure.in
index 7dded28f22..9bc4663d1a 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -755,16 +755,6 @@ AH_BOTTOM([
#endif /* KRB5_AUTOCONF_H */
])
-# Not used yet, but let's find out what we've got on the platforms
-# we're working with....
-AC_CHECK_HEADERS(inttypes.h stdint.h)
-AC_CHECK_TYPES([uint32_t, int32_t, uint64_t, int64_t, uint_least32_t, uintptr_t, uintmax_t, long long], , , [
-#ifdef HAVE_STDINT_H
-# include <stdint.h>
-#elif defined(HAVE_INTTYPES_H)
-# include <inttypes.h>
-#endif
-])
AC_CHECK_TYPES([struct cmsghdr, struct in_pktinfo, struct in6_pktinfo, struct sockaddr_storage], , , [
#include <sys/types.h>
#include <sys/socket.h>
@@ -872,14 +862,6 @@ AC_CHECK_PROG(RUNTEST,runtest,runtest)
AC_CHECK_PROG(PERL,perl,perl)
# lib/gssapi
-AC_CHECK_HEADER(stdint.h,[
- include_stdint='awk '\''END{printf("%cinclude <stdint.h>\n", 35);}'\'' < /dev/null'],
- include_stdint='echo "/* no stdint.h */"')
-AC_SUBST(include_stdint)
-AC_CHECK_HEADER(inttypes.h,[
- include_inttypes='awk '\''END{printf("%cinclude <inttypes.h>\n", 35);}'\'' < /dev/null'],
- include_inttypes='echo "/* no inttypes.h */"')
-AC_SUBST(include_inttypes)
AC_CHECK_HEADER(xom.h,[
include_xom='awk '\''END{printf("%cinclude <xom.h>\n", 35);}'\'' < /dev/null'], [
include_xom='echo "/* no xom.h */"'])
@@ -965,45 +947,6 @@ fi
AC_SUBST(GSSRPC__SYS_PARAM_H)
AC_SUBST(GSSRPC__NETDB_H)
-AC_CACHE_CHECK([for uint32_t in sys/types.h],
- [krb5_cv_header_sys_types_h_uint32_t],
- [AC_TRY_COMPILE([#include <sys/types.h>],
- [uint32_t i = 0;],
- [krb5_cv_header_sys_types_h_uint32_t=yes],
- [krb5_cv_header_sys_types_h_uint32_t=no])])
-AC_CACHE_CHECK([for uint32_t in stdint.h],
- [krb5_cv_header_stdint_h_uint32_t],
- [AC_TRY_COMPILE([#include <stdint.h>],
- [uint32_t i = 0;],
- [krb5_cv_header_stdint_h_uint32_t=yes],
- [krb5_cv_header_stdint_h_uint32_t=no])])
-AC_CACHE_CHECK([for uint32_t in inttypes.h],
- [krb5_cv_header_inttypes_h_uint32_t],
- [AC_TRY_COMPILE([#include <inttypes.h>],
- [uint32_t i = 0;],
- [krb5_cv_header_inttypes_h_uint32_t=yes],
- [krb5_cv_header_inttypes_h_uint32_t=no])])
-GSSRPC__STDINT_H='/* #include <stdint.h> */'
-GSSRPC__INTTYPES_H='/* #include <inttypes.h> */'
-GSSRPC__FAKE_UINT32='/* #undef GSSRPC__FAKE_INT32 */'
-if test $krb5_cv_header_sys_types_h_uint32_t = yes; then
- : # already included sys/types.h
-else
- if test $krb5_cv_header_stdint_h_uint32_t = yes; then
- GSSRPC__STDINT_H='#include <stdint.h>'
- else
- if test $krb5_cv_header_inttypes_h_uint32_t = yes; then
- GSSRPC__INTTYPES_H='#include <inttypes.h>'
- else
- AC_MSG_WARN([can't find a fixed-width 32-bit type anywhere; faking it])
- GSSRPC__FAKE_UINT32='#define GSSRPC__FAKE_UINT32 1'
- fi
- fi
-fi
-AC_SUBST(GSSRPC__STDINT_H)
-AC_SUBST(GSSRPC__INTTYPES_H)
-AC_SUBST(GSSRPC__FAKE_UINT32)
-
AC_CACHE_CHECK([for BSD type aliases], [krb5_cv_type_bsdaliases],
[AC_TRY_COMPILE(
[#include <sys/types.h>