summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorKen Raeburn <raeburn@mit.edu>2011-09-18 09:43:30 +0000
committerKen Raeburn <raeburn@mit.edu>2011-09-18 09:43:30 +0000
commit0bc7ef8f41450025e5024ba428cef2ec36fd1076 (patch)
tree9adc032c1bb0eb8355d184bbe53dee65105971e4 /src/configure.in
parentab30d5d27a4f4ab67d4e9232fbbfd6acd799a2b8 (diff)
downloadkrb5-0bc7ef8f41450025e5024ba428cef2ec36fd1076.tar.gz
krb5-0bc7ef8f41450025e5024ba428cef2ec36fd1076.tar.xz
krb5-0bc7ef8f41450025e5024ba428cef2ec36fd1076.zip
Don't check for memmove, inet_ntoa, inet_aton, pthread.h, or
semaphore.h, since the results of the tests are never used. git-svn-id: svn://anonsvn.mit.edu/krb5/trunk@25182 dc483132-0cff-0310-8789-dd5450dbe970
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in5
1 files changed, 2 insertions, 3 deletions
diff --git a/src/configure.in b/src/configure.in
index 10d1c46c6a..961f80967b 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -51,7 +51,6 @@ AC_ARG_ENABLE([athena],
# Begin autoconf tests for the Makefiles generated out of the top-level
# configure.in...
-AC_CHECK_FUNCS(memmove)
KRB5_BUILD_LIBOBJS
KRB5_BUILD_LIBRARY
KRB5_BUILD_PROGRAM
@@ -220,7 +219,7 @@ AC_CONFIG_HEADERS(include/autoconf.h, [echo timestamp > include/autoconf.stamp])
AC_PROG_LEX
AC_C_CONST
AC_HEADER_DIRENT
-AC_CHECK_FUNCS(strdup setvbuf inet_ntoa inet_aton seteuid setresuid setreuid setegid setresgid setregid setsid flock fchmod chmod strftime strptime geteuid setenv unsetenv getenv gmtime_r localtime_r bswap16 bswap64 mkstemp getusershell access getcwd srand48 srand srandom stat strchr strerror strerror_r timegm)
+AC_CHECK_FUNCS(strdup setvbuf seteuid setresuid setreuid setegid setresgid setregid setsid flock fchmod chmod strftime strptime geteuid setenv unsetenv getenv gmtime_r localtime_r bswap16 bswap64 mkstemp getusershell access getcwd srand48 srand srandom stat strchr strerror strerror_r timegm)
AC_CHECK_FUNC(mkstemp,
[MKSTEMP_ST_OBJ=
@@ -233,7 +232,7 @@ AC_SUBST(MKSTEMP_ST_OBJ)
AC_SUBST(EXTRA_SUPPORT_SYMS)
DECLARE_SYS_ERRLIST
-AC_CHECK_HEADERS(unistd.h paths.h regex.h regexpr.h fcntl.h memory.h ifaddrs.h sys/filio.h byteswap.h machine/endian.h machine/byte_order.h sys/bswap.h endian.h pwd.h arpa/inet.h alloca.h dlfcn.h limits.h pthread.h semaphore.h)
+AC_CHECK_HEADERS(unistd.h paths.h regex.h regexpr.h fcntl.h memory.h ifaddrs.h sys/filio.h byteswap.h machine/endian.h machine/byte_order.h sys/bswap.h endian.h pwd.h arpa/inet.h alloca.h dlfcn.h limits.h)
AC_CHECK_HEADER(regexp.h, [], [],
[#define INIT char *sp = instring;
#define GETC() (*sp++)