summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorGreg Hudson <ghudson@mit.edu>2013-01-28 20:15:01 -0500
committerGreg Hudson <ghudson@mit.edu>2013-01-28 20:31:19 -0500
commit0b1dc2f93da4c860dd27f1ac997617b712dff383 (patch)
tree42708b1e4393c9fe3f49969aefb8143844189533 /src/configure.in
parent2743fdee849be4a00a9ea72d601004c95b22dd56 (diff)
downloadkrb5-0b1dc2f93da4c860dd27f1ac997617b712dff383.tar.gz
krb5-0b1dc2f93da4c860dd27f1ac997617b712dff383.tar.xz
krb5-0b1dc2f93da4c860dd27f1ac997617b712dff383.zip
Refactor LDAP DB option parsing code
krb5_ldap_open and krb5_ldap_create contain two large, almost identical blocks of DB option processing code. Factor it out into a new function krb5_ldap_parse_db_params in ldap_misc.c, and simplify the factored-out code. Create a helper function to add server entries and use it to simplify krb5_ldap_read_server_params as well as DB option parsing. Since the new DB option helper uses isspace instead of isblank, we no longer require portability goop for isblank.
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/configure.in b/src/configure.in
index c5c599b57b..600cc8d905 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -120,7 +120,6 @@ KRB5_NEED_PROTO([#include <string.h>
/* Solaris 8 declares swab in stdlib.h. */
#include <stdlib.h>
],swab,1)
-KRB5_NEED_PROTO([#include <ctype.h>],isblank,1)
AC_PROG_AWK
KRB5_AC_INET6
@@ -263,7 +262,7 @@ AC_CONFIG_HEADERS(include/autoconf.h, [echo timestamp > include/autoconf.stamp])
AC_PROG_LEX
AC_C_CONST
AC_HEADER_DIRENT
-AC_CHECK_FUNCS(strdup setvbuf seteuid setresuid setreuid setegid setresgid setregid setsid flock fchmod chmod strftime strptime geteuid setenv unsetenv getenv gmtime_r localtime_r bswap16 bswap64 mkstemp getusershell access getcwd srand48 srand srandom stat strchr strerror strerror_r timegm isblank)
+AC_CHECK_FUNCS(strdup setvbuf seteuid setresuid setreuid setegid setresgid setregid setsid flock fchmod chmod strftime strptime geteuid setenv unsetenv getenv gmtime_r localtime_r bswap16 bswap64 mkstemp getusershell access getcwd srand48 srand srandom stat strchr strerror strerror_r timegm)
AC_CHECK_FUNC(mkstemp,
[MKSTEMP_ST_OBJ=