summaryrefslogtreecommitdiffstats
path: root/dhash/configure.ac
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2009-05-12 11:51:20 -0400
committerSimo Sorce <ssorce@redhat.com>2009-05-14 11:34:04 -0400
commite54ce04c11c4a6ff8b5c7bbbd738f70e3da4e101 (patch)
treec2f1993b7192d9b8dd2b8c6c3e96de6884362743 /dhash/configure.ac
parent5d237157deefb39db63acdd950bd67c7809415f6 (diff)
downloadding-libs-e54ce04c11c4a6ff8b5c7bbbd738f70e3da4e101.tar.gz
ding-libs-e54ce04c11c4a6ff8b5c7bbbd738f70e3da4e101.tar.xz
ding-libs-e54ce04c11c4a6ff8b5c7bbbd738f70e3da4e101.zip
Enable modular build of common SSSD libraries
Allow configuration and build of individual SSSD utility libraries from their own subdirectories. Building all utilities is still possible recursively from the common root.
Diffstat (limited to 'dhash/configure.ac')
-rw-r--r--dhash/configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/dhash/configure.ac b/dhash/configure.ac
new file mode 100644
index 0000000..13fd1ac
--- /dev/null
+++ b/dhash/configure.ac
@@ -0,0 +1,20 @@
+AC_INIT([dhash], [0.3.3], [jdennis@redhat.com])
+AC_CONFIG_SRCDIR([dhash.c])
+AC_CONFIG_AUX_DIR([build])
+AM_INIT_AUTOMAKE([-Wall -Werror foreign])
+AC_PROG_CC
+AC_PROG_LIBTOOL
+AC_CONFIG_MACRO_DIR([m4])
+AC_PROG_INSTALL
+
+AC_CONFIG_HEADERS([config.h])
+
+# Enable trace build
+AC_ARG_ENABLE([trace],
+ [AS_HELP_STRING([--enable-trace[=LEVEL]],[build with low level tracing enabled])],
+ [trace_level="$enableval"],
+ [trace_level="0"])
+AS_IF([test ["$trace_level" -gt "0"] -a ["$trace_level" -lt "8"] ],[AC_SUBST([TRACE_VAR],["-DTRACE_LEVEL=$trace_level"])])
+
+AC_CONFIG_FILES([Makefile dhash.pc])
+AC_OUTPUT \ No newline at end of file