summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2012-05-11 09:31:24 -0400
committerJan Zeleny <jzeleny@redhat.com>2012-05-15 09:08:24 +0200
commit013e9da407a3b583db93f827f054cd2fd6127739 (patch)
tree389e1a44fc70b3e0a52c72a54c45bcd5986338f3 /Makefile.am
parent6b3bc0158926ed03536c6c72b3847b8c04ace864 (diff)
downloadding-libs-013e9da407a3b583db93f827f054cd2fd6127739.tar.gz
ding-libs-013e9da407a3b583db93f827f054cd2fd6127739.tar.xz
ding-libs-013e9da407a3b583db93f827f054cd2fd6127739.zip
Fix issue when running make distcheck
When running 'make distcheck', all files in the $srcdir are set to read-only, to ensure that the build does not modify the source. However, this broke our ability to test file permissions. We will now copy the file to the builddir and do the tests there, where we have control.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4b74b28..167bc1f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -289,6 +289,7 @@ endif
clean-local-ini_config:
rm -f ./*.out
rm -f test.ini
+ rm -f ./foo.conf #From ini_parse_ut
##############################################################################
# Additional rules