summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac55
1 files changed, 55 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..7c68604
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,55 @@
+AC_INIT([CrashCatcher], [0.0.1], [jmoskovc@redhat.com, zprikryl@redhat.com])
+
+AM_INIT_AUTOMAKE([-Wall -Werror foreign])
+
+AC_DISABLE_STATIC
+AC_PROG_LIBTOOL
+
+AC_PROG_CXX
+
+PKG_CHECK_MODULES([DBUS_GLIB], [dbus-glib-1])
+PKG_CHECK_MODULES([SQLITE3], [sqlite3])
+PKG_CHECK_MODULES([GTKMM], [gtkmm-2.4])
+
+AC_CHECK_HEADER([sys/inotify.h], [],
+ [AC_MSG_ERROR([sys/inotify.h is needed to build CrashCatcher])])
+
+PLUGINS_CONF_DIR='${libdir}/${PACKAGE_NAME}'
+AC_ARG_WITH(pluginsconfdir,
+ [AS_HELP_STRING([--with-pluginsconfdir=[DIR]],
+ [Directory where plugin's configuration files are])],
+ [PLUGINS_CONF_DIR=$withval])
+AC_SUBST(PLUGINS_CONF_DIR)
+
+PLUGINS_LIB_DIR='${libdir}/${PACKAGE_NAME}'
+AC_ARG_WITH(pluginslibdir,
+ [AS_HELP_STRING([--with-pluginslibdir=DIR],
+ [Directory where plugin's libraries are])],
+ [PLUGINS_LIB_DIR=$withval])
+AC_SUBST(PLUGINS_LIB_DIR)
+
+DEBUG_DUMPS_DIR='${prefix}/var/cache/${PACKAGE_NAME}'
+AC_ARG_WITH(debugdumpsdir,
+ [AS_HELP_STRING([--with-debugdumpdir=DIR],
+ [Directory where debugdumps are created])],
+ [DEBUG_DUMPS_DIR="$withval"])
+AC_SUBST(DEBUG_DUMPS_DIR)
+
+AC_SUBST(DL_LIBS, -ldl)
+
+AC_CONFIG_HEADERS([config.h])
+
+AC_CONFIG_FILES([
+ Makefile
+ lib/Makefile
+ lib/DBus/Makefile
+ lib/DebugDump/Makefile
+ lib/MiddleWare/Makefile
+ lib/Plugins/Makefile
+ src/Makefile
+ src/Daemon/Makefile
+ src/Hooks/Makefile
+ src/Applet/Makefile
+])
+
+AC_OUTPUT \ No newline at end of file