summaryrefslogtreecommitdiffstats
path: root/src/Gui/Makefile.am
diff options
context:
space:
mode:
authorDenys Vlasenko <vda.linux@googlemail.com>2009-07-20 17:29:58 +0200
committerDenys Vlasenko <vda.linux@googlemail.com>2009-07-20 17:29:58 +0200
commitb21a17491ab4eab43b871da791a8a8ef84489be1 (patch)
treea26607739338f0ed6eacf20a2888f3f72d4cffb0 /src/Gui/Makefile.am
parentf8338de268b159bd90d0753f4e21697d83a87cc3 (diff)
downloadabrt-b21a17491ab4eab43b871da791a8a8ef84489be1.tar.gz
abrt-b21a17491ab4eab43b871da791a8a8ef84489be1.tar.xz
abrt-b21a17491ab4eab43b871da791a8a8ef84489be1.zip
Fix build system for the case where configure was run with non-default prefix
Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
Diffstat (limited to 'src/Gui/Makefile.am')
-rw-r--r--src/Gui/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/Gui/Makefile.am b/src/Gui/Makefile.am
index e797173..9112cf8 100644
--- a/src/Gui/Makefile.am
+++ b/src/Gui/Makefile.am
@@ -14,4 +14,9 @@ EXTRA_DIST = $(PYTHON_FILES) $(GLADE_FILES) abrt-gui abrt.desktop
pkgdata_PYTHON = $(PYTHON_FILES)
pkgdata_DATA = $(GLADE_FILES)
-CLEANFILES := $(notdir $(wildcard *~)) $(notdir $(wildcard *\#)) $(notdir $(wildcard \.\#*)) $(notdir $(wildcard *.pyc)) \ No newline at end of file
+CLEANFILES := $(notdir $(wildcard *~)) $(notdir $(wildcard *\#)) $(notdir $(wildcard \.\#*)) $(notdir $(wildcard *.pyc))
+
+install-exec-hook:
+ for b in $(bin_SCRIPTS); do \
+ sed 's:/usr/share:$(datadir):g' -i $(DESTDIR)$(bindir)/$$b || exit $$?; \
+ done