summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@gmail.com>2012-05-14 19:07:35 +0200
committerMarc-André Lureau <marcandre.lureau@gmail.com>2012-05-14 23:27:20 +0200
commit8e1a8b32421aaf4c8f0e5dd1f75b456e631f339f (patch)
tree42fcf17a63a9864e12138d803f6b201ee404c08b /src/Makefile.am
parent88893e30bc49833749464bfff4c369cb50bf7fb9 (diff)
downloadvirt-viewer-8e1a8b32421aaf4c8f0e5dd1f75b456e631f339f.tar.gz
virt-viewer-8e1a8b32421aaf4c8f0e5dd1f75b456e631f339f.tar.xz
virt-viewer-8e1a8b32421aaf4c8f0e5dd1f75b456e631f339f.zip
dist: ship .ico in tarball
Some distros (a 4-letters) don't have icotool. Let's ship the .ico in the tarball. The build will fail if icoutil is not installed when building from git or when the .ico is absent. The error should be explicit.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6b7d2ee..d99b043 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -121,7 +121,7 @@ desktop_DATA = remote-viewer.desktop
EXTRA_DIST += $(desktop_DATA)
VIRT_VIEWER_RES = virt-viewer.rc virt-viewer.manifest
-ICONDIR = $(top_builddir)/icons
+ICONDIR = $(top_srcdir)/icons
MANIFESTDIR = $(srcdir)
EXTRA_DIST += $(VIRT_VIEWER_RES)
@@ -130,7 +130,7 @@ bin_PROGRAMS += windows-cmdline-wrapper
windows_cmdline_wrapper_SOURCES = windows-cmdline-wrapper.c
windows_cmdline_wrapper_LDFLAGS = -lpsapi
-virt-viewer_rc.$(OBJEXT): $(VIRT_VIEWER_RES) $(top_builddir)/icons/virt-viewer.ico
+virt-viewer_rc.$(OBJEXT): $(VIRT_VIEWER_RES) $(ICONDIR)/virt-viewer.ico
$(AM_V_GEN)$(WINDRES) \
-DICONDIR='\"$(ICONDIR)\"' \
-DMANIFESTDIR='\"$(MANIFESTDIR)\"' \