summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHans de Goede <hdegoede@redhat.com>2011-09-26 13:01:56 +0200
committerHans de Goede <hdegoede@redhat.com>2011-09-26 14:24:00 +0200
commit571948ffb78eddd3015c456d084e0ca941f3e45d (patch)
tree2816ac6dea9ee2c7a58323bb6851fc1a0e574deb /configure.ac
parent3cf8fa7d31a3ebf1d051ba0e1bd3df9957bdb112 (diff)
downloadvd_agent-571948ffb78eddd3015c456d084e0ca941f3e45d.tar.gz
vd_agent-571948ffb78eddd3015c456d084e0ca941f3e45d.tar.xz
vd_agent-571948ffb78eddd3015c456d084e0ca941f3e45d.zip
vdagentd: Autogenerate a Xinerama xorg.conf for multi monitor setups
The autogenerated file will get written as /etc/X11/xorg.conf.spice Signed-off-by: Hans de Goede <hdegoede@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6c9c156..c4659f8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,14 +18,24 @@ AC_ARG_ENABLE([console-kit],
[enable_console_kit="$enableval"],
[enable_console_kit="yes"])
+AC_ARG_ENABLE([pciaccess],
+ [AS_HELP_STRING([--enable-pciaccess], [Enable libpciaccess use for auto generation of Xinerama xorg.conf (default: yes)])],
+ [enable_pciaccess="$enableval"],
+ [enable_pciaccess="yes"])
+
PKG_PROG_PKG_CONFIG
PKG_CHECK_MODULES(X, [xfixes xrandr xinerama x11])
+PKG_CHECK_MODULES(SPICE, [spice-protocol >= 0.8.0])
if test x"$enable_console_kit" = "xyes" ; then
PKG_CHECK_MODULES(DBUS, [dbus-1])
AC_DEFINE([HAVE_CONSOLE_KIT], [1], [If defined, vdagentd will be compiled with ConsoleKit support] )
fi
AM_CONDITIONAL(HAVE_CONSOLE_KIT, test x"$enable_console_kit" = "xyes")
-PKG_CHECK_MODULES(SPICE, [spice-protocol >= 0.8.0])
+if test x"$enable_pciaccess" = "xyes" ; then
+ PKG_CHECK_MODULES(PCIACCESS, [pciaccess >= 0.10])
+ AC_DEFINE([HAVE_PCIACCESS], [1], [If defined, vdagentd will be compiled with pciaccess support] )
+fi
+AM_CONDITIONAL(HAVE_PCIACCESS, test x"$enable_pciaccess" = "xyes")
AC_CONFIG_FILES([
Makefile