summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHans de Goede <hdegoede@redhat.com>2013-01-07 14:58:45 +0100
committerHans de Goede <hdegoede@redhat.com>2013-01-07 21:44:26 +0100
commit407a184050778d2240c5bb50659532ca34318fa3 (patch)
tree96f19c63fbf3a839db044d04d1019ba61a6e5d1f /configure.ac
parent47ebbb21909ac0b36a31d335502fe83a410939dd (diff)
downloadvd_agent-407a184050778d2240c5bb50659532ca34318fa3.tar.gz
vd_agent-407a184050778d2240c5bb50659532ca34318fa3.tar.xz
vd_agent-407a184050778d2240c5bb50659532ca34318fa3.zip
randr: Use XRRGetScreenResourcesCurrent (rhbz#888821)
Using XRRGetScreenResources, causes the X-server to actively check for new monitors, which generates Xrandr events even if nothing is changed, which causes gnome-setting-manager to muck with the settings, racing with the agent doing the same. XRRGetScreenResourcesCurrent OTOH simply returns the last known settings without any polling of the hardware and matching events being involved. So use XRRGetScreenResourcesCurrent instead of XRRGetScreenResources, with one exception. When the number of monitors is changed, so some outputs are enabled or disabled, then the hardware polling is necessary to properly reflect the connected / disconnected state in xrandr. This requires Xrandr >= 1.3, note that since 0.12.0 we already depended on >= 1.2 anyways, this patch raises the requirement to 1.3 and makes it explict. Signed-off-by: Hans de Goede <hdegoede@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 68ed0e8..149c652 100644
--- a/configure.ac
+++ b/configure.ac
@@ -76,7 +76,7 @@ AC_ARG_ENABLE([static-uinput],
[enable_static_uinput="$enableval"],
[enable_static_uinput="no"])
-PKG_CHECK_MODULES(X, [xfixes xrandr xinerama x11])
+PKG_CHECK_MODULES(X, [xfixes xrandr >= 1.3 xinerama x11])
PKG_CHECK_MODULES(SPICE, [spice-protocol >= 0.8.0])
if test "$with_session_info" = "auto" || test "$with_session_info" = "systemd"; then