summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorHans de Goede <hdegoede@redhat.com>2013-04-11 15:53:11 +0200
committerHans de Goede <hdegoede@redhat.com>2013-04-11 17:24:56 +0200
commita3dea8eb4b7175eb22e15f5696fbc186464a033b (patch)
tree8387e316c88b0fd7d19c27a0f32ddae543231934 /Makefile.am
parentdd8b05ab01e20a3bf5e39405e74ee912184062c0 (diff)
downloadvd_agent-a3dea8eb4b7175eb22e15f5696fbc186464a033b.tar.gz
vd_agent-a3dea8eb4b7175eb22e15f5696fbc186464a033b.tar.xz
vd_agent-a3dea8eb4b7175eb22e15f5696fbc186464a033b.zip
vdagentd: Allow runtime disabling of session-info (rhbz#904084)
Add spice-vdagent -X cmdline option, which runtime disables console-kit / systemd-logind integration for setups where these are not used. This is useful for using pre-build binaries (ie distro binaries) in such setups. Signed-off-by: Hans de Goede <hdegoede@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c551e0b..a539d2d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,9 +17,12 @@ src_spice_vdagentd_SOURCES = src/vdagentd.c \
src/udscs.c
if HAVE_CONSOLE_KIT
src_spice_vdagentd_SOURCES += src/console-kit.c
-endif
+else
if HAVE_LIBSYSTEMD_LOGIN
src_spice_vdagentd_SOURCES += src/systemd-login.c
+else
+src_spice_vdagentd_SOURCES += src/dummy-session-info.c
+endif
endif
noinst_HEADERS = src/session-info.h \