summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2014-02-04 17:57:17 +0100
committerChristophe Fergeau <cfergeau@redhat.com>2014-02-25 16:30:27 +0100
commit7d858d5064fd0c26454b72bf9fe3e0472f31e34f (patch)
tree717bc7e081408ab96ece54240057884c810c0533 /Makefile.am
parentfa42110482171f82153596cbee766e3d1b84c925 (diff)
downloadvd_agent-7d858d5064fd0c26454b72bf9fe3e0472f31e34f.tar.gz
vd_agent-7d858d5064fd0c26454b72bf9fe3e0472f31e34f.tar.xz
vd_agent-7d858d5064fd0c26454b72bf9fe3e0472f31e34f.zip
Fix gdm autostart path
gdm 3.1.90 (June 2011) changed the path where .desktop files which should be autostarted with gdm needs to be located. This used to be $(datadir)/gdm/autostart/LoginWindow and is now $(datadir)/gdm/greeter/autostart. This means that when running gdm in a VM in a recent distribution, arbitrary resizing the VM window will not cause the resolution to be adjusted. This used to be working in eg RHEL6. This patch installs the .desktop file to both paths in order to work both with older and newer gdms.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 74cc313..7fae742 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -42,9 +42,12 @@ noinst_HEADERS = src/glib-compat.h \
xdgautostartdir = $(sysconfdir)/xdg/autostart
xdgautostart_DATA = $(top_srcdir)/data/spice-vdagent.desktop
-gdmautostartdir = $(datadir)/gdm/autostart/LoginWindow
+gdmautostartdir = $(datadir)/gdm/greeter/autostart
gdmautostart_DATA = $(top_srcdir)/data/spice-vdagent.desktop
+gdmautostart2dir = $(datadir)/gdm/autostart/LoginWindow
+gdmautostart2_DATA = $(top_srcdir)/data/spice-vdagent.desktop
+
install-data-local:
$(mkdir_p) $(DESTDIR)$(localstatedir)/run/spice-vdagentd