summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2011-03-25 17:17:41 +0100
committerHans de Goede <hdegoede@redhat.com>2011-04-04 14:04:24 +0200
commit58573d15f4308ba391c16ca0c5316d167b63d7d4 (patch)
tree09c219b64c67d5e810e70cf55d59ba3eda5f1b45 /Makefile.am
parent7aaac6881e0e906901ab50a14497151935835d0b (diff)
downloadvd_agent-58573d15f4308ba391c16ca0c5316d167b63d7d4.tar.gz
vd_agent-58573d15f4308ba391c16ca0c5316d167b63d7d4.tar.xz
vd_agent-58573d15f4308ba391c16ca0c5316d167b63d7d4.zip
make console-kit use optional
On older distributions (namely RHEL5), console-kit is not available. This patch makes console-kit use optional, though this means vd_agentd won't handle properly user-switching. This patch makes it always use the first client vdagent, or none if multiple agents connect.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index eb0cc20..6ed8aa2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,8 +12,10 @@ src_spice_vdagentd_LDADD = $(DBUS_LIBS) $(SPICE_LIBS)
src_spice_vdagentd_SOURCES = src/vdagentd.c \
src/vdagentd-uinput.c \
src/vdagent-virtio-port.c \
- src/console-kit.c \
src/udscs.c
+if HAVE_CONSOLE_KIT
+src_spice_vdagentd_SOURCES += src/console-kit.c
+endif
noinst_HEADERS = src/console-kit.h \
src/vdagentd-proto-strings.h \