summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorVictor Toso <victortoso@redhat.com>2015-03-06 18:14:21 +0100
committerVictor Toso <victortoso@redhat.com>2015-04-24 17:31:20 +0200
commit010dc21f35fb3997ade6717e10c6a3b52a1737ba (patch)
tree4953776547694800f58833b3c1778ac868dd8546 /Makefile.am
parent6c0160e8a3a3902817088dc5e7e8bdccaeaec1b4 (diff)
downloadvd_agent-010dc21f35fb3997ade6717e10c6a3b52a1737ba.tar.gz
vd_agent-010dc21f35fb3997ade6717e10c6a3b52a1737ba.tar.xz
vd_agent-010dc21f35fb3997ade6717e10c6a3b52a1737ba.zip
audio: add functions to set volume/mute with alsa
This patch includes the vdagent-audio.[ch] files in order to communicate with backend audio server. The two functions provide a way to set volume and mute in the guest by connecting to default mixer control in alsa which is 'Master' for playback and 'Capture' for record.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 510f460..cf5d0f5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,9 +4,14 @@ NULL =
bin_PROGRAMS = src/spice-vdagent
sbin_PROGRAMS = src/spice-vdagentd
-src_spice_vdagent_CFLAGS = $(X_CFLAGS) $(SPICE_CFLAGS) $(GLIB2_CFLAGS)
-src_spice_vdagent_LDADD = $(X_LIBS) $(SPICE_LIBS) $(GLIB2_LIBS)
-src_spice_vdagent_SOURCES = src/vdagent.c src/vdagent-x11.c src/vdagent-x11-randr.c src/vdagent-file-xfers.c src/udscs.c
+src_spice_vdagent_CFLAGS = $(X_CFLAGS) $(SPICE_CFLAGS) $(GLIB2_CFLAGS) $(ALSA_CFLAGS)
+src_spice_vdagent_LDADD = $(X_LIBS) $(SPICE_LIBS) $(GLIB2_LIBS) $(ALSA_LIBS)
+src_spice_vdagent_SOURCES = src/vdagent.c \
+ src/vdagent-x11.c \
+ src/vdagent-x11-randr.c \
+ src/vdagent-file-xfers.c \
+ src/vdagent-audio.c \
+ src/udscs.c
src_spice_vdagentd_CFLAGS = $(DBUS_CFLAGS) $(LIBSYSTEMD_LOGIN_CFLAGS) \
$(PCIACCESS_CFLAGS) $(SPICE_CFLAGS) $(GLIB2_CFLAGS) $(PIE_CFLAGS)
@@ -30,6 +35,7 @@ endif
noinst_HEADERS = src/glib-compat.h \
src/session-info.h \
src/udscs.h \
+ src/vdagent-audio.h \
src/vdagent-file-xfers.h \
src/vdagent-virtio-port.h \
src/vdagent-x11.h \