summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index b62d98c0..4c01c313 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -10,6 +10,7 @@ AM_CPPFLAGS = \
$(SLIRP_CFLAGS) \
$(SMARTCARD_CFLAGS) \
$(SSL_CFLAGS) \
+ $(LIBWEBSOCKETS_CFLAGS) \
$(VISIBILITY_HIDDEN_CFLAGS) \
$(WARN_CFLAGS) \
$(NULL)
@@ -38,6 +39,7 @@ libspice_server_la_LIBADD = \
$(SLIRP_LIBS) \
$(SSL_LIBS) \
$(Z_LIBS) \
+ $(LIBWEBSOCKETS_LIBS) \
$(NULL)
libspice_server_la_SOURCES = \
@@ -93,6 +95,13 @@ libspice_server_la_SOURCES = \
zlib_encoder.h \
$(NULL)
+if SUPPORT_WEBSOCKETS
+libspice_server_la_SOURCES += \
+ reds_websockets.c \
+ reds_websockets.h \
+ $(NULL)
+endif
+
if SUPPORT_TUNNEL
libspice_server_la_SOURCES += \
red_tunnel_worker.c \