summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7fb636f7..9dbfccfa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -272,6 +272,19 @@ if test "$red_target" = "x11"; then
AC_SUBST(MISC_X_LIBS)
fi
+PKG_CHECK_MODULES(XINERAMA,
+ xinerama >= 1.0,
+ have_xinerama=yes,
+ have_xinerama=no)
+
+AM_CONDITIONAL([HAVE_XINERAMA], [test "x$have_xinerama" = "xyes"])
+if test "x$have_xinerama" = "xyes" ; then
+ AC_DEFINE([HAVE_XINERAMA], [], [Define if we have Xinerama])
+ AC_SUBST(XINERAMA_CFLAGS)
+ AC_SUBST(XINERAMA_LIBS)
+ SPICE_REQUIRES+=" xinerama"
+fi
+
# Add parameter for (partial) static linkage of spice client.
# this is used to achive single binary package for all (?) distros.
AC_ARG_ENABLE(static-linkage,
@@ -508,6 +521,8 @@ echo "
Have XRANDR 1.2: ${have_xrandr12}
+ Have Xinerama: ${have_xinerama}
+
Support tunneling: ${enable_tunnel}
Red target: ${red_target}