summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 10 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 6c277506..69714259 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
+NULL =
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = common server python_modules
-DIST_SUBDIRS = spice-protocol $(SUBDIRS)
+SUBDIRS = spice-common server
if SUPPORT_CLIENT
SUBDIRS += client
@@ -10,9 +10,11 @@ endif
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = spice-server.pc
-DISTCLEANFILES = \
- spice-server.pc
-
-EXTRA_DIST = spice.proto spice1.proto spice_codegen.py
-
-DISTCHECK_CONFIGURE_FLAGS=--enable-opengl --enable-gui --enable-tunnel --enable-smartcard --with-sasl --enable-automated-tests
+DISTCHECK_CONFIGURE_FLAGS = \
+ --enable-automated-tests \
+ --enable-gui \
+ --enable-opengl \
+ --enable-smartcard \
+ --enable-tunnel \
+ --with-sasl \
+ $(NULL)