summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2013-10-10 11:17:52 +0200
committerChristophe Fergeau <cfergeau@redhat.com>2013-10-10 11:17:52 +0200
commitceb672bf85f99af9290e0576224072ff6c7533c9 (patch)
treec904626065927eacb4120ea7d6616ca435a5802e /server/Makefile.am
parentf78f1ae61b6af9262b1a8d1ffbf162b323549b83 (diff)
downloadspice-ceb672bf85f99af9290e0576224072ff6c7533c9.tar.gz
spice-ceb672bf85f99af9290e0576224072ff6c7533c9.tar.xz
spice-ceb672bf85f99af9290e0576224072ff6c7533c9.zip
Use hardened linker flags if available
This commit reuse several macros from libvirt to test for support for "-Wl,-z -Wl,relro", "-Wl,-z -Wl,now" and "-Wl,--no-copy-dt-needed-entries", and use them if available.
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index 8cbd87b3..0f8888df 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -21,6 +21,8 @@ lib_LTLIBRARIES = libspice-server.la
libspice_server_la_LDFLAGS = \
-version-info $(SPICE_LT_VERSION) \
-no-undefined \
+ $(RELRO_LDFLAGS) \
+ $(NO_INDIRECT_LDFLAGS) \
$(NULL)
if HAVE_LD_VERSION_SCRIPT