summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorJavier Celaya <javier.celaya@flexvm.es>2014-11-13 17:00:58 +0100
committerChristophe Fergeau <cfergeau@redhat.com>2014-12-02 19:41:17 +0100
commitb532ef0866cefe260ad0f08550f7c40d3580d0d7 (patch)
tree29a0c98c41d61178cc0ac66db359073caacd05b8 /server/Makefile.am
parent84b3a5079d6014d50e3018b24949d5a2e18e3c78 (diff)
downloadspice-b532ef0866cefe260ad0f08550f7c40d3580d0d7.tar.gz
spice-b532ef0866cefe260ad0f08550f7c40d3580d0d7.tar.xz
spice-b532ef0866cefe260ad0f08550f7c40d3580d0d7.zip
Add LZ4 compression support.
- Add lz4 encoder to compress an image of type LZ4 (see spice_common). - Add code in red_worker to use LZ4 when it is enabled, and the client supports it through its display capability, or fallback to LZ. - Add enable_lz4 switch in the configure script. Show LZ4 support at the end.
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index f162a184..3cef2430 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -6,6 +6,7 @@ AM_CPPFLAGS = \
-DRED_STATISTICS \
$(COMMON_CFLAGS) \
$(GLIB2_CFLAGS) \
+ $(LZ4_CFLAGS) \
$(PIXMAN_CFLAGS) \
$(SASL_CFLAGS) \
$(SLIRP_CFLAGS) \
@@ -35,6 +36,7 @@ libspice_server_la_LIBADD = \
$(GL_LIBS) \
$(GLIB2_LIBS) \
$(JPEG_LIBS) \
+ $(LZ4_LIBS) \
$(LIBRT) \
$(PIXMAN_LIBS) \
$(SASL_LIBS) \
@@ -75,6 +77,8 @@ libspice_server_la_SOURCES = \
inputs_channel.h \
jpeg_encoder.c \
jpeg_encoder.h \
+ lz4_encoder.c \
+ lz4_encoder.h \
main_channel.c \
main_channel.h \
mjpeg_encoder.c \