summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorAlon Levy <alevy@redhat.com>2010-09-15 15:55:37 +0200
committerAlon Levy <alevy@redhat.com>2010-12-07 13:31:44 +0200
commit7e0a1dfa75d9c967b96929c56dce4cecb7151a85 (patch)
tree4ec0b7cd9442d8353878f10007bf3c3c629dbc9f /server/Makefile.am
parentd99ec6c35b02a64950c4397644a9a81fad1d4492 (diff)
downloadspice-7e0a1dfa75d9c967b96929c56dce4cecb7151a85.tar.gz
spice-7e0a1dfa75d9c967b96929c56dce4cecb7151a85.tar.xz
spice-7e0a1dfa75d9c967b96929c56dce4cecb7151a85.zip
smartcard: configure option --enable-smartcard
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index ff7b4851..2c86a2c0 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -17,6 +17,7 @@ INCLUDES = \
-DRED_STATISTICS \
$(WARN_CFLAGS) \
$(VISIBILITY_HIDDEN_CFLAGS) \
+ $(SMARTCARD_CFLAGS) \
$(NULL)
spice_built_sources = generated_marshallers.c generated_marshallers.h generated_demarshallers.c
@@ -81,6 +82,15 @@ else
TUNNEL_SRCS =
endif
+if SUPPORT_SMARTCARD
+SMARTCARD_SRCS = \
+ smartcard.c \
+ smartcard.h \
+ $(NULL)
+else
+SMARTCARD_SRCS =
+endif
+
libspice_server_la_SOURCES = \
demarshallers.h \
glz_encoder.c \
@@ -121,6 +131,7 @@ libspice_server_la_SOURCES = \
zlib_encoder.h \
char_device.h \
$(TUNNEL_SRCS) \
+ $(SMARTCARD_SRCS) \
$(COMMON_SRCS) \
$(GL_SRCS) \
$(NULL)