summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorAlon Levy <alevy@redhat.com>2011-10-30 17:04:59 +0200
committerAlon Levy <alevy@redhat.com>2011-11-08 14:59:49 +0200
commit776bdd6c95715dcd8e609dc3ff647d0ad73fd339 (patch)
treed39addbae110ce4d421f4ad968adafbc1c38987b /server/Makefile.am
parent9174b67160157f74cc00faf0b42cb7c5d2b710a1 (diff)
downloadspice-776bdd6c95715dcd8e609dc3ff647d0ad73fd339.tar.gz
spice-776bdd6c95715dcd8e609dc3ff647d0ad73fd339.tar.xz
spice-776bdd6c95715dcd8e609dc3ff647d0ad73fd339.zip
server: introduce dispatcher
used for main_dispatcher only in this patch. Dispatcher is meant to be used for Main<->any low frequency messages. It's interface is meant to include the red_dispatcher usage: fixed size messages per message type some messages require an ack Some methods are added to be used by RedDispatcher later: dispatcher_handle_read - to be called directly by RedDispatcher epoll based loop dispatcher_set_opaque - to be set from red_worker pthread dispatcher_init - allow NULL core as used by red_worker Read and Write behavior: Sender: blocking write, blocking read for ack (if any). Reader: poll for any data, if such then blocking read for a message_type and following message. repeat until poll returns with no pending data to read. FDO Bugzilla: 42463
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index 418d707c..34a6b47b 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -78,6 +78,8 @@ libspice_server_la_SOURCES = \
red_client_cache.h \
red_client_shared_cache.h \
red_common.h \
+ dispatcher.c \
+ dispatcher.h \
red_dispatcher.c \
red_dispatcher.h \
main_dispatcher.c \