summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorGerd Hoffmann <kraxel@redhat.com>2011-07-19 13:46:39 +0200
committerGerd Hoffmann <kraxel@redhat.com>2011-07-19 14:39:28 +0200
commit70135614623d573def52d062ccce34ffc42a5d0f (patch)
tree5c8f9d936e7bbe31719e5aa9c0033f7db112757a /server/Makefile.am
parentf045886a0623fcec38c390c31570971b4fb8d2d5 (diff)
downloadspice-70135614623d573def52d062ccce34ffc42a5d0f.tar.gz
spice-70135614623d573def52d062ccce34ffc42a5d0f.tar.xz
spice-70135614623d573def52d062ccce34ffc42a5d0f.zip
server: add symbol versioning to the spice server shared library.
This patch adds symbol versions to the spice server library. Each symbol which is exported by libspice-server gets tagged with the (stable) version where it appeared first. This way the linker and rpm are able to figure which version of the spice-server libary is required by a particular qemu binary/package. Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index 601840ab..d94f9fb1 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -34,6 +34,7 @@ lib_LTLIBRARIES = libspice-server.la
libspice_server_la_LDFLAGS = \
-version-number $(SPICE_LT_VERSION) \
+ -Wl,--version-script=spice-server.syms \
-no-undefined \
$(NULL)