summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorYonit Halperin <yhalperi@redhat.com>2012-06-24 08:33:21 +0300
committerYonit Halperin <yhalperi@redhat.com>2012-07-03 14:13:41 +0300
commit50e3af6a995eb8aeee8bd8fb82a5cf6aa93f21cf (patch)
treea5447fd8301d77bf4b92c976c2ca18066edd249e /server/Makefile.am
parent713505c800a9dad3f320198377651816da75f50c (diff)
downloadspice-50e3af6a995eb8aeee8bd8fb82a5cf6aa93f21cf.tar.gz
spice-50e3af6a995eb8aeee8bd8fb82a5cf6aa93f21cf.tar.xz
spice-50e3af6a995eb8aeee8bd8fb82a5cf6aa93f21cf.zip
char_device: Introducing shared flow control code for char devices.
SpiceCharDeviceState manages the (1) write-to-device queue (2) wakeup and reading from the device (3) client tokens (4) sending messages from the device to the client/s, considering the available tokens. SpiceCharDeviceState can be also stopped and started. When the device is stopped, no reading or writing is done from/to the device. Messages addressed from the client to the device are being queued. Later, an api for stop/start will be added to spice.h and it should be called from qemu. This patch does not yet remove the wakeup callback from SpiceCharDeviceState, but once all the char devices (agent/spicevmc/smartcard) code will switch to the new implementation, SpiceCharDeviceState will be moved to the c file and its reference to the wakeup callback will be removed.
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index 47b3c10b..e7b49775 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -43,6 +43,7 @@ libspice_server_la_LIBADD = \
libspice_server_la_SOURCES = \
agent-msg-filter.c \
agent-msg-filter.h \
+ char_device.c \
char_device.h \
demarshallers.h \
glz_encoder.c \