summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2012-03-21 14:42:35 +0100
committerMarc-André Lureau <marcandre.lureau@redhat.com>2012-03-25 18:59:10 +0200
commit359fc1cb5dbbcf32132c3e8ee6f881a23deff684 (patch)
tree3ae7cc1c8b4d0449d50a13cb9640a6ef75f51f11 /server/Makefile.am
parent4df135c858d7dfb1aa0ae5d3cb17d786410d1544 (diff)
downloadspice-359fc1cb5dbbcf32132c3e8ee6f881a23deff684.tar.gz
spice-359fc1cb5dbbcf32132c3e8ee6f881a23deff684.tar.xz
spice-359fc1cb5dbbcf32132c3e8ee6f881a23deff684.zip
Use the spice-common submodule
This patch will replace the common/ directory with the spice-common project. It is for now a simple project subdirectory shared with spice-gtk, but the goal is to make it a proper library later on. With this change, the spice-server build is broken. The following commits fix the build, and have been seperated to ease the review. v2 - moves all the generated marshallers to spice-common library - don't attempt to fix windows VS build, which should somehow be splitted with spice-common (or built from tarball only to avoid generation tools/libs deps) v3 - uses libspice-common-client - fix a mutex.h inclusion reported by Alon
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am47
1 files changed, 15 insertions, 32 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index a88e464a..97e7dfed 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -1,14 +1,11 @@
-SUBDIRS = . tests
-
NULL =
+SUBDIRS = . tests
-INCLUDES = \
- -I$(top_srcdir) \
- -I$(top_srcdir)/common \
+AM_CPPFLAGS = \
-DRED_STATISTICS \
$(CELT051_CFLAGS) \
+ $(COMMON_CFLAGS) \
$(PIXMAN_CFLAGS) \
- $(PROTOCOL_CFLAGS) \
$(SASL_CFLAGS) \
$(SLIRP_CFLAGS) \
$(SMARTCARD_CFLAGS) \
@@ -17,18 +14,6 @@ INCLUDES = \
$(WARN_CFLAGS) \
$(NULL)
-spice_built_sources = generated_marshallers.c generated_marshallers.h generated_demarshallers.c
-
-generated_demarshallers.c: $(top_srcdir)/spice.proto
- $(AM_V_GEN)$(PYTHON) $(top_srcdir)/spice_codegen.py --generate-demarshallers --server --include red_common.h $(top_srcdir)/spice.proto generated_demarshallers.c
-
-STRUCTS=-M String -M Rect -M Point -M DisplayBase -M Fill -M Opaque -M Copy -M Blend -M Blackness -M Whiteness -M Invers -M Rop3 -M Stroke -M Text -M Transparent -M AlphaBlend
-generated_marshallers.c: $(top_srcdir)/spice.proto
- $(AM_V_GEN)$(PYTHON) $(top_srcdir)/spice_codegen.py --include red_common.h --generate-marshallers $(STRUCTS) --server $(top_srcdir)/spice.proto generated_marshallers.c
-
-generated_marshallers.h: $(top_srcdir)/spice.proto
- $(AM_V_GEN)$(PYTHON) $(top_srcdir)/spice_codegen.py --generate-marshallers $(STRUCTS) --server -H $(top_srcdir)/spice.proto generated_marshallers.h
-
lib_LTLIBRARIES = libspice-server.la
libspice_server_la_LDFLAGS = \
@@ -41,17 +26,18 @@ libspice_server_la_LDFLAGS += \
-Wl,--version-script=$(top_srcdir)/server/spice-server.syms
endif
-libspice_server_la_LIBADD = \
- $(top_builddir)/common/libspice-common.la \
- $(CELT051_LIBS) \
- $(GL_LIBS) \
- $(JPEG_LIBS) \
- $(LIBRT) \
- $(PIXMAN_LIBS) \
- $(SASL_LIBS) \
- $(SLIRP_LIBS) \
- $(SSL_LIBS) \
- $(Z_LIBS) \
+libspice_server_la_LIBADD = \
+ $(top_builddir)/spice-common/common/libspice-common.la \
+ $(top_builddir)/spice-common/common/libspice-common-server.la \
+ $(CELT051_LIBS) \
+ $(GL_LIBS) \
+ $(JPEG_LIBS) \
+ $(LIBRT) \
+ $(PIXMAN_LIBS) \
+ $(SASL_LIBS) \
+ $(SLIRP_LIBS) \
+ $(SSL_LIBS) \
+ $(Z_LIBS) \
$(NULL)
libspice_server_la_SOURCES = \
@@ -59,9 +45,6 @@ libspice_server_la_SOURCES = \
agent-msg-filter.h \
char_device.h \
demarshallers.h \
- generated_demarshallers.c \
- generated_marshallers.c \
- generated_marshallers.h \
glz_encoder.c \
glz_encoder.h \
glz_encoder_config.h \